Mic mute button doesn't work. Need help or additional info.

asked 2014-04-27 08:19:21 -0500

bogeual gravatar image

Hi, folks! I have Thinkpad T520 and Fedora 20 x86_64 with resent updates installed. I use Gnome 3 as my DE. I switched BIOS video settings from "NVidia Optimus" to "Discrete Video" (with this settings I have no problem with transfer video and sound to my TV through DisplayPort for now). But in this case mic mute button doesn't work. There is no response to pressing it with finger at all! What I have found is that it still can be activated manually through Pulse Audio Volume Control -> Input Devices -> Mute audio. With BIOS video settings "Optimus" I can use this button. After press it, indicator turn on, mic is mute and activated Gnome OSD-status. Do you have any ideas about how to force work mic mute button with "Discrete Video" option enabled?

edit retag flag offensive close merge delete

Comments

You can set a keyboard shortcut (in this case one that uses the "mic mute" button) to toggle any sound mixer channel you want.

First, find out how many audio cards you have on the system:

cat /proc/asound/cards

then list the available mixer channels for each card:

amixer -c0

if there's more than one card, then modify the number after -c in the amixer command (0 for first card, 1 for second card... etc, this should be easy looking at the contents of /proc/asound/cards).

Please update your original post with the output of these commands.

Ahmad Samir gravatar imageAhmad Samir ( 2014-05-01 03:21:26 -0500 )edit

Hi! Thanks for replay! Actually, I've tried to set a shortcut though Gnome Control Center, but I got fault. There is no any reaction on pressing mic mute button (and ThinkVantage too).

bogeual gravatar imagebogeual ( 2014-05-03 09:14:41 -0500 )edit

I found a temporary solution yesterday. I run in gnome terminal following command:

su -c 'echo 0x07ffffff > /sys/devices/platform/thinkpad_acpi/hotkey_mask'.

After that mic mute button and ThinkVantage button started work as usual. Are there any ways to make this change during system boot?

bogeual gravatar imagebogeual ( 2014-05-03 09:21:14 -0500 )edit

You can use /etc/rc.d/rc.local to execute that command at boot; create that file and make it executable, the first line should be:

#!/bin/sh

then put the echo command in it on a new line; since this is executed as root you don't need the su -c bit.

Ahmad Samir gravatar imageAhmad Samir ( 2014-05-03 10:56:59 -0500 )edit

Hi! I tried to do this... But without success. Another steps I tried (separately):

  1. Create /etc/X11/xinit/xinitrc.d/thinkpad-acpi.sh with

    #!/bin/sh
    /usr/bin/echo '0x07ffffff' > /sys/devices/platform/thinkpad_acpi/hotkey_mask

  2. Create /etc/modprobe.d/thinkpad_acpi.conf with

    options thinkpad_acpi hotkey=0x07ffffff

  3. Create /etc/tmpfiles.d/thinkpad.conf with

    w /sys/devices/platform/thinkpad_acpi/hotkey_mask - - - - 0x07ffffff

But nothing was changed. Maybe my problem in somehow connected with changing "Optimus" to "Descrete Graphic" in BIOS? But I really need it.

bogeual gravatar imagebogeual ( 2014-05-05 05:10:37 -0500 )edit