Ask Your Question
0

Display configuration

asked 2014-04-27 04:21:43 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

My laptop is Fujitsu ah531. I've installed Fedora 20 recenly and it appeared that my eyes got tired too quickly as if refresh rate was too low. I updated Fedora and installed Intel Graphics Installer and so updated drivers there, but it's still the same. I've printed xrandr in terminal and it showed me the same configuration as in Windows:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192 LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm 1366x768 60.0*+ 1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis) HDMI1 disconnected (normal left inverted right x axis y axis) DP1 disconnected (normal left inverted right x axis y axis)

And I read everywhere that it can't be refresh rate, because in LCD it does't matter. Like here ( http://docs.fedoraproject.org/en-US/Fedora/20/html/Power_Management_Guide/Enhanced_Graphics_Power_Management.html ):

Typically, the screen receives fresh data sixty times per second (a frequency of 60 Hz). When a screen and a graphics controller are linked by LVDS, the LVDS system uses power on every refresh cycle. When idle, the refresh rate of many LCD screens can be dropped to 30 Hz without any noticeable effect (unlike cathode ray tube (CRT) monitors, where a decrease in refresh rate produces a characteristic flicker)

So, what can it be?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-28 04:38:36 -0500

cobra gravatar image

You are correct about the refresh rates not really affecting the image. For old CRT displays, the light given off by the phosphorous coating inside the tube would decay, and had to be refreshed. These devices scanned across the whole display many times a second.

You don't have that problem with LCD displays because once the phase is set in the liquid crystal, it remains at that state rather than decaying. Refreshing means 'changing' the state of the LCD dot to the same state once again. Therefore you don't get the flicker that you experience with CRTs.

There are several other things that could be causing your eyes to tire quickly. Check some of these - you don't actually have to answer these, but just be sure in your own mind that they're not the cause:

  • What is the brightness and contrast levels set for your display, this can have a huge impact on eye tiredness
  • How long have you had your laptop, is it new and different to the one you are used to?
  • What size font are you using? Have you switched from another OS where the text was just bigger?
  • What colour scheme are you using? If you use a heavy mix of red and green, for example, you might find that your eyes are struggling with the definition. Your particular eyes might instead struggle with other colour combinations making them more tired.
  • Do you wear glasses? Due an eye-check? Not looking to be humorous here, it's just a suggestion at a possible cause.

If you can change stuff around with the colour and/or brightness settings, especially avoid using overly bright screen in dim light, you might make things a bit easier.

edit flag offensive delete link more

Comments

Thank you for your answer.

  • I'm using the same laptop, I just installed Fedora in parallel with Windows. So now I can switch and clearly see the difference;
  • By default there're only two options concerning contrast and the same for font size in Fedora's graphic interface configuration menu. Do I have to use terminal or is there some additional software that can help me with that?
  • Is there an analogue to Windows' Cleartype? Again maybe some additional sw?
  • How to manage the lack of fonts in Fedora?
Demetr gravatar imageDemetr ( 2014-05-02 13:58:18 -0500 )edit

You can try tweaking font settings; assuming you're running GNOME, install gnome-tweak-tool then launch it and go to the Fonts tab, you can tweak the hinting style and the antialiasing settings.

If you're still not statisfied install the freetype-freeworld package from Rpm Fusion, that package enables LCD sub-pixel rendering. Note that packages from the Rpm Fusion repos can't be included in the official Fedora repos due to e.g. software patents, checkout their FAQ before enabling those repos.

Ahmad Samir gravatar imageAhmad Samir ( 2014-05-07 04:28:22 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-27 04:21:43 -0500

Seen: 867 times

Last updated: May 02 '14