Ask Your Question
0

How to reliably connect to internet from inside KVM?

asked 2014-04-22 11:10:26 -0500

vijaym gravatar image

updated 2014-04-22 22:36:00 -0500

mether gravatar image

I installed Debian Wheezy inside Fedora 20 KVM using Virtual Machine Manager. Installation went smoothly but sometimes I am not able to connect to internet from Debian VM. Some times connection is there but it is very slow connection. What are the changes I have to make to make connection more reliable?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-22 15:36:18 -0500

tonioc gravatar image

Can you elaborate on how you declared the network in your VM: bridged? NATed ? other? I've been using virt-manager with KVM/Qemu for a while and several kinds of network interfaces with no performance issue, and no such random behaviour.

edit flag offensive delete link more

Comments

This is first time I am using KVM so I just used default settings. In the Virt manager it shows default is virbr0.

vijaym gravatar imagevijaym ( 2014-04-22 15:46:26 -0500 )edit

In default settings, virt-manager used NAT mode: merely some kind of virtual router between host and guest. When you have this slow connection, check system performance tools on both host and guest sides: top and other system monitor things to determine what's going on. You also can check in ifconfig results (virbr0, vnet0) => counters there.

tonioc gravatar imagetonioc ( 2014-04-22 16:22:56 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-22 11:10:26 -0500

Seen: 283 times

Last updated: Apr 22 '14