Ask Your Question
1

Fedora 20 CPU Fan Thermal control

asked 2014-04-22 08:35:37 -0500

Moipersoin gravatar image

updated 2014-09-05 18:04:29 -0500

Running Fedora 20 On Asus Laptop.

CPU fan was automatically changing speed according to system load and CPU temp. (After a fresh install of fedora 20) At some point this has stopped working. (After a Kernel update using YUMEX)

Have tried installing LM_Sensors, TLP, Smartfan etc ... Nothing works...

Machine will auto shutdown on over temp, when it is restarted the fan will work at max speed and stay there, The fan will set itself on boot up according to cpu temp (The BIOS is obviously doing this), Once fedora is booted it remains the same, The only way I can controll or use the machine is usualy to turn it on, load up the cpu and then reboot so that the fan is on full speed constantly.

This laptop is an old Intel Pentium M (Pentium 3 Mobile) With ATI R600 graphics ... Running at 2GHZ max ... Its 8years+ Old (It runs quite well on linux ...)

I have tried other Linux Distros(Mostly the debian based varieties) And it works fine, But I prefer my fedora... Any suggestions?

PS: On a completely seperate subject... I have a DELL desktop that I use as a HCPC, Fedora is the Only distro that will support the Audio hardware correctly (Intel I5).... Go figure...

edit retag flag offensive close merge delete

Comments

Please add if the fan stopped working, is always slow or always at high speed...

markusN gravatar imagemarkusN ( 2014-05-04 16:04:54 -0500 )edit

Fans (CPU/GPU) not running at all after resume resulting in overheat and shutdown - Fedora 20 / Dell Studio 17 (1737)

viking gravatar imageviking ( 2014-05-04 16:50:34 -0500 )edit

PS I am new to Fedora but not to Linux, even though not a power user, I will be happy to provide any additional info if needed (but I have no idea at the momment what would be helpful and how to get it ;) ).

viking gravatar imageviking ( 2014-05-05 06:36:41 -0500 )edit

Perhaps "simply" a mechanical problem? I am right now on an ASUS laptop which behaves properly.

markusN gravatar imagemarkusN ( 2014-05-05 13:28:01 -0500 )edit

I'm using a ThinkPad T540p with Fedora 20. Computer runs extremely hot, up to 99C having a limit of 100C. This is not good. I checked the file /proc/acpi/ibm/fan and fan is at speed 0. The file /proc/acpi/ibm/thermal is not there which worries me since most systems use this file to control read the temperature and kick in the fan. Installed thinkfan utility to start the fan manually but since the file /proc/acpi/ibm/thermal is not there, it just doesn't work either.

Has anyone looked into this? Doesn't look right and need answer. Computer cannot be running this hot.

Pepito gravatar imagePepito ( 2014-07-12 00:52:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-12 04:32:00 -0500

Madeye gravatar image

I hit this problem recently - didn't even manage to complete the install of Fedora 20 before thermal shutdown. I managed to isolate the problem to the open source radeon drivers - these seem to default to High power mode, which on my laptop [i7-2760QM / Radeon 6990M] gives an unsustainable temperature.

To fix the problem, I installed Fedora with basic graphics mode enabled, removed "nomodeset" from the boot line then installed Radeon Power Profile Manager ( https://extensions.gnome.org/extension/356/radeon-power-profile-manager/ ) and set the power mode to Low before the machine shutdown.

If your machine boots ok already, the last of these steps should be enough to fix the problem.

edit flag offensive delete link more

Comments

Thanks, but AFAIK no thermal shutdown ever occurred on my laptop: fans are working, the only issue is that I cannot control them. Beside the fact I don't have radeon cards, I think I tried using nomodeset, but without results. I have to double-check and try again, though, because I may be wrong about that. Thanks again

akiross gravatar imageakiross ( 2014-11-18 17:48:08 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-22 08:35:37 -0500

Seen: 7,637 times

Last updated: Oct 12 '14