Ask Your Question
1

Fedora 20 kernel 3.13.9-200 display resolution

asked 2014-04-19 17:16:39 -0500

mjrofra gravatar image

updated 2014-09-28 16:08:10 -0500

mether gravatar image

Hello,

I have installed Fedora 20 on a Lenovo y400. Works great but the display resolution I get is 1024x768 and I don't have the option for 1368x768 which is my laptop screen resolution.

When I boot with Kernel 3.11.10-301 instead of the default 3.13.9-200 I get the correct screen resolution: 1368x768.

I have tried the gnome, kde and xfce desktops but got the same problem with all of them.

Can somebody give me some indication on how to get the 1368x768 screen resolution with the default Kernel 3.13.9-200 or what may be the problem here.

UPDATE 2014-04-20:

This is the Xorg.0.log file after booting with the 3.13.9 Kernel and -wrong- 1024x768 screen resolution.

This is the Xorg.0.log file after booting with the 3.11.10 Kernel and -correct- 1368x768 screen resolution.

edit retag flag offensive close merge delete

Comments

After booting the kernel in question, upload /var/log/Xorg.0.log to http://fpaste.org , you can use this command in terminal:

fpaste /var/log/Xorg.0.log

and post the link it'll print here.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-20 00:08:23 -0500 )edit
1

Hi Ahmad, here's my Xorg.0.log.

mjrofra gravatar imagemjrofra ( 2014-04-20 09:27:41 -0500 )edit

The log indicates that KMS (kernel mode setting) is disabled for some reason, so the default nouveau driver can't be used and the system is falling back to the very basic vesa driver.

Let's have a look at dmesg:

dmesg | fpaste
Ahmad Samir gravatar imageAhmad Samir ( 2014-04-20 09:54:02 -0500 )edit

Thank you Ahmad, here's dmesg.

mjrofra gravatar imagemjrofra ( 2014-04-20 15:32:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-21 04:49:01 -0500

Ahmad Samir gravatar image

(This isn't really an answer but a comment has a small characters limit..)

From dmesg output:

nouveau E[   VBIOS][0000:01:00.0] 0x83e0[ ]: unknown opcode 0x42
nouveau E[ DEVINIT][0000:01:00.0] init failed, -22
nouveau E[     DRM] failed to create 0x80000080, -22
nouveau: probe of 0000:01:00.0 failed with error -22

so it's failing to load the nouveau driver. I've found similar reports in other distros (Debian, Arch).

I think you should file a bug report at https://bugzilla.redhat.com and post the output of:

lspci -nn

and attach /tmp/dmesg.log which will be created after running this command (must be run when you boot the defective kernel):

dmesg > /tmp/dmesg.log
edit flag offensive delete link more

Comments

The problem is likely Fedora's outdated nouveau. I had a similar problem with Fedora 20 running vesa for my GeForce GT 635 card and getting only 1024x768. The Ubuntu live CD runs the same system at 1920x1080 with its newer nouveau. The Ubuntu nouveau is 1.1.1, Fedora 20's is 1.0.9.

stpeters43 gravatar imagestpeters43 ( 2014-06-09 15:19:02 -0500 )edit

I guess you mean nouveau 1.0.10, this the latest I can find in upstream git.

I think your issue is different than mjrofra; his problem is with the newer kernel, i.e. something that changed in the nouveau kernel module, since his card works well with the older kernel. Whereas your issue is that the nouveau X driver, 1.0.9, didn't recognise your card and the newer 1.0.10 supports it now according to the upstream git commit log.

Ahmad Samir gravatar imageAhmad Samir ( 2014-06-10 05:58:49 -0500 )edit

Question Tools

Stats

Asked: 2014-04-19 17:16:39 -0500

Seen: 1,037 times

Last updated: Apr 21 '14