Ask Your Question
1

Lenovo notebook can not shutdown, suspend or hibernate properly. Reboot works. What can cause this?

asked 2014-04-18 06:44:20 -0500

imoj gravatar image

updated 2014-04-18 11:33:01 -0500

When a command to shutdown/hibernate/suspend is issued the system will go down properly. But then it will not power off. Instead it keeps running with a black screen. Resetting the notebook is the only way to stop it then.

The system is a fresh installation of fedora 20 on a Lenovo ideapad. The installation failed due to an error while installing the bootloader. The bootloader was installed manually later.

So: What are possible reasons and how can they be diagnosed?

EDIT: When shutdown the last message displayed is something like:

[ACPI:] preparing system for sleep sate S5

When hibernated/suspended the display turns black while the system is still running.

edit retag flag offensive close merge delete

Comments

Have you tried explicitly instructing the machine to power off after the system is brought down with a command such as shutdown -P now?

bitwiseoperator gravatar imagebitwiseoperator ( 2014-04-18 09:39:23 -0500 )edit

I don't understand what you mean?!

shutdown -P now

Results in the behaviour described above.

imoj gravatar imageimoj ( 2014-04-18 11:30:39 -0500 )edit

I guess your installation problem didn't have anything in common with your issue. I've been having similar problems like yours for ages - one kernel update works, the next update doesn't, or one day a working system stops hibernating/suspending for no reason. First advice: check Lenovo's website and look for BIOS updates (broken ACPI implementations may be a culprit).

fidelleon gravatar imagefidelleon ( 2014-04-18 12:01:05 -0500 )edit

Yeah it definetly is a broken ACPI implementation. The annoying issue is that I had a working Linux Mint 14 installation until recently when my hdd failed. I don't understand what is different for fedora20.

imoj gravatar imageimoj ( 2014-04-18 12:07:21 -0500 )edit

Even using the same kernel release and numbers, each distro patches its kernel in so many ways you can have different behaviour between them. Debian/Ubuntu puts around 50MB of patches, so does RedHat/Fedora. With distro A I could hibernate but had hard disk controller errors - distro B doesn't allow me to hibernate but no problem with my disks. Go figure.

fidelleon gravatar imagefidelleon ( 2014-04-18 13:03:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-21 10:56:52 -0500

imoj gravatar image

updated 2014-04-22 04:39:57 -0500

TLDR; Fedora 20 can no be installed on a msdos disk due to a bug. A workaround is to create msdos partition table and convert it to GPT, then install and convert it back. After that update /etc/fstab and grub.

Ok, I wanted a far more general answer, but at least for me (Ideapad s205) this solution gets hibernation and suspension working. At the moment of writing I stilll get the DREADED grub boot prompt when booting or rebooting though. (12 and 13 fix the boot prompt.)

  1. Create a msdos partition table with a layout like this: (Obviously msdos -> GPT vice versa is not necessarily)
  2. 100 or 200 MB "efi" partition to fool the installer necessary due to this bug.
  3. Boot partition with enough space (~1GB)
  4. Whatever partions you need.
  5. Use gdisk to convert the partition to a GPT partition
  6. Install Fedora (For me this fails when the bootloader is installed.)
  7. Boot and using gdisk convert the disk back to msdos
  8. Delete the /boot/efi partition and mark the /boot partition as bootable using gparted/fdisk
  9. grub2-mkconfig -o /boot/grub2/grub.cfg
  10. grub2-install --boot-directory=/boot /dev/sda (target needs to match your architecture)
  11. Have working hibernation.
  12. Due to the installation on a GPT disk, the fstab contains UUID partition labels. The disk partition table contains msdos labels though. Obviously the fstab needs to be rewritten. In my case I just replaced the UUID by the correct label.
  13. The old grub.cfg possibly still contains the UUIDs therefor another run of grub2-mkconfig -o /boot/grub2/grub.cfg is necessary to update it accordingly.

Sadly this probably only works EFI-hybrids as my ideapad. Good luck for everyone else.

EDIT: Correction due to randomuser's comment.

EDIT: Added the fstab rewriting and TLDR.

edit flag offensive delete link more

Comments

1

You need to point grub2-mkconfig at the file you want it to write, either -o /boot/grub2/grub.cfg or -o /boot/efi/EFI/fedora/grub.cfg. Am I understanding correctly that your laptop doesn't suspend if you boot Fedora via UEFI, but the system doesn't allow you to disable UEFI and do BIOS style booting?

randomuser gravatar imagerandomuser ( 2014-04-21 18:11:10 -0500 )edit

First of all, thanks for the correction. I simply forgot to add it as I wrote it from memory. Secondly, the model I have is now 3 years old and it was one of the first model coming with a EFI. It is not a pure EFI implementation but a hybrid capable of a legacy Bios mode. Booting, shutdown and hibernation were always troublesome with the s205 especially with the grub2-efi. I had the same problem for years with ubunti, mint and other distributions. For your last question: The notebook has no switch to enable bios or efi mode. I'm not sure but I think it just looks at the HDD to determine it.

imoj gravatar imageimoj ( 2014-04-22 01:39:29 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-18 06:44:20 -0500

Seen: 3,148 times

Last updated: Apr 22 '14