Ask Your Question

Change ctrl+alt+del behavior

asked 2014-04-17 05:14:33 -0500

Fabricio gravatar image

I, sinner, confess... :-) I'm too used to M$ Windows Ctrl+Alt+Del behavior where the default selected action button (which I normally execute by pressing the space bar) is to Lock the session. On the other hand, in Fedora, the default selected action is Power Off... And, as you may well guess, I keep unwillingly powering off my machine... :-( I know Ctrl+Alt+L does the session locking directly but I keep using the Ctrl+Alt+Del + Space bar by force of use...

So, my questions is: Is there a way of adding the Lock action to the Ctrl+Alt+Del popup and make it the default selected action?

Thank you!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-04-17 08:16:15 -0500

Fabricio gravatar image

I managed to figure out a workaround for this problem. I went to Settings > Keyboard > Shortcuts tab > System, disabled Log out (which was assigned to Ctrl+Alt+Del and assigned that key combination to Lock screen. This will directly lock the screen when Ctrl+Alt+Del is pressed without asking any question but it's better then a shut down of the computer... :-) I hope it helps other poor Windows shoot-from-the-hip screen lockers out there.

edit flag offensive delete link more

answered 2014-04-17 05:49:56 -0500

tonioc gravatar image

In my F20/KDE, the ctrl-alt-del sequence triggers a dialog to shutdown or logout.

What do you have in /etc/systemd/system/ ?

edit flag offensive delete link more



Yes. But the default is shutdown and even logout would be too cumbersome to have as default because it would kill all applications in the process. Anyway, I figured a workaround and will post it as an answer to my own question.

Fabricio gravatar imageFabricio ( 2014-04-17 08:09:46 -0500 )edit

Question Tools

1 follower


Asked: 2014-04-17 05:14:33 -0500

Seen: 2,170 times

Last updated: Apr 17 '14