Ask Your Question
0 undefined symbol: unixd_config

asked 2014-04-12 00:27:42 -0500

n4rky gravatar image


This is a fresh Fedora 20 installation. I have not (yet) added any non-standard repositories. I am attempting to configure apache 2.4.

It's basically a stock configuration with an old Debian/Ubuntu sites-available/sites-enabled structure that dates back a while copied in because I have multiple domains and subdomains. But do let me know what configuration bits I need to post.

Here's what I'm seeing and can't see what to do about:

[root@m0404 conf.d]# apachectl -t
httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.modules.d/00-ssl.conf: Cannot load modules/ into server: /etc/httpd/modules/ undefined symbol: unixd_config

What now?


edit retag flag offensive close merge delete


I don't have enough karma points to upvote, but reinstalling mod_ssl worked. Thanks!

n4rky gravatar imagen4rky ( 2014-04-12 09:30:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-04-12 08:19:20 -0500

marcindulak gravatar image

updated 2014-04-12 08:20:54 -0500

Most likely you have copied also the contents of /etc/httpd/modules/ from the old (apache22) installation. There should be no references to unixd_config on Fedora 20, only to apach24 ap_unixd_config (see ). If there are - it's a bug to be reported at Do:

su -c "yum -y reinstall mod_ssl"  # "yum -y install mod_ssl" # if mod_ssl not installed

but generally i would recommend a fresh Fedora installation, and installing the necessary apache modules with yum, one-by-one.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-04-12 00:27:42 -0500

Seen: 5,041 times

Last updated: Apr 12 '14