Ask Your Question
0

How to configure the firewall to watch Freebox TV streams (channel available in Totem 3.12)

asked 2014-04-11 12:06:41 -0500

remjg gravatar image

updated 2014-04-13 05:03:02 -0500

Hi,

With my internet provider, I can watch TV from a computer. It has been included in GNOME Videos 3.12 (Totem) as a channel but I need to disable the firewall each time I want to watch it with the following command:

systemctl stop firewalld

To configure the firewall, I tried to use netstat to find the ports to open. Here are the relevant lines:

# netstat
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 vostro3300:54631        192.168.0.10:rtsp       TIME_WAIT  
tcp        0      0 vostro3300:50084        192.168.0.254:54242     CLOSE_WAIT 
tcp        1      0 vostro3300:39023        freeplayer.freebox:http CLOSE_WAIT 
tcp        0      0 vostro3300:60641        freeplayer.freebox:rtsp ESTABLISHED

Unfortunately, these ports change each time I restart GNOME Videos...

How could I configure the firewall to allow RTSP streams?


Edit : since the wikipedia page about RTSP mentions the port 554, I added in firewall-config a new service with ports 554 UDP and TCP opened. The service is activated for my zone of connection (home) but as I expected nothing changed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-26 04:15:08 -0500

remjg gravatar image

I have filled a bug report on bugzilla.gnome.org ( bug 728789), and the answer is very clear: the firewall will have to be disabled (at least temporary) to watch any stream from this channel.

Temporary stop the firewall

To temporary stop the firewall, you can use the following command:

sudo systemctl stop firewalld

Then if you want to restart it, use this:

sudo systemctl start firewalld

Permanently disable the firewall

To permanently disable the firewall:

sudo systemctl disable firewalld

If you want to enable it again, you can use this:

sudo systemctl enable firewalld
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-04-11 12:06:41 -0500

Seen: 701 times

Last updated: Apr 26 '14