Ask Your Question
0

Fedora 20 restarts instead of shutting down

asked 2014-04-10 12:40:54 -0500

Corif gravatar image

updated 2014-04-10 14:52:14 -0500

mether gravatar image

In Fedora 20, when ever I try to hit the shutdown button it will shutdown Fedora but then my computer will turn back on and ask if I want to boot to Fedora or Windows 8(dual booting). I am not sure why fedora isnt completely shutting down my computer. Windows 8 will shut it down no problem but Fedora will always make it restart.

edit retag flag offensive close merge delete

Comments

I have the same problem: my computer is a Intel NUC, bios updated to latest version, dual boot Windows 7 and Fedora 20 (with gnome 3.12). I noticed that if I logoff from my user and then I push the shutdown button, most of the time the computer does shutdown.... but not all the times. I also tried to send the command "shutdown now" from terminal, but even in that case, sometimes, the computer reboot instead of shutting down.

Nicola P. gravatar imageNicola P. ( 2014-05-09 02:34:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-11-19 20:48:43 -0500

The best possible solution is mentioned in this page : https://www.behnke.io/fedora-17-on-an...

I have tried all above solution but most of the time the solutions are static (top working after few major updates) The following seems to work some of the time : Switch on blutooth, use pendrive always pluged in

edit flag offensive delete link more
0

answered 2014-05-16 12:23:21 -0500

Nicola P. gravatar image

I had the same problem with my Intel NUC, dual boot F20 and Windows 7.
I did some research and the problem seems to be related to the interaction between BIOS and Linux.

Some people solved it updating to the last BIOS version, see for instance this forum:
https://communities.intel.com/thread/47751?start=105&tstart=0.
In my case the latest BIOS (which solved the problem for the Intel NUC) was still a beta and I did not want to run the risk.

I also found this other post related to the same problem with Ubuntu:
http://askubuntu.com/questions/132143/stuck-on-reboot-and-shutdown/135568#135568

They were proposing to add "acpi=noirq" at the end of line GRUB_CMDLINE_LINUX_DEFAULT in the grub file

sudo gedit /etc/default/grub

set

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

then

sudo update-grub

For many people this seems to have solved the problem. I read acpi=noirq suffices for standard booting, which simply doesn't use ACPI for irq routing, I was not sure if it could have side effects and I did not try it.

Still from the first Intel forum, I found another solution: they suggested to change BIOS parameters to enable "Deep S4/S5" (deeper sleep) and to disable "Wake on LAN" (WOL allows you to boot your computer using an ethernet cable).

I tried it and that solved my problem. Hope it works for you.

Ciao

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-04-10 12:40:54 -0500

Seen: 3,050 times

Last updated: May 16 '14