Ask Your Question
0

How to fix "nm-connection-editor-0.9.9.0-9.git20140123.fc20.x86_64 has missing requires of libgnome-bluetooth.so.12()(64bit)" ?

asked 2014-04-05 21:07:12 -0500

mbatista gravatar image

updated 2014-04-05 23:27:31 -0500

When I try to update my fedora 20 I get these following errors:

Error: Package: colord-gtk-0.1.25-2.fc20.x86_64 (@koji-override-0/$releasever)
          Requires: libcolordprivate.so.2()(64bit)
          Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
              libcolordprivate.so.2()(64bit)
          Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
              Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolordprivate.so.2()(64bit)
          Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
              libcolordprivate.so.2()(64bit)
Error: Package: colord-gtk-0.1.25-2.fc20.x86_64 (@koji-override-0/$releasever)
           Requires: libcolord.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
              libcolord.so.2()(64bit)
          Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
              Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolord.so.2()(64bit)
          Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
              libcolord.so.2()(64bit)
Error: Package: gtk3-3.12.0-2.fc20.x86_64 (rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolord.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
              libcolord.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
              Not found
          Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
              libcolord.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
           libcolord.so.2()(64bit)
Error: Package: gnome-settings-daemon-3.12.0.1-2.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolord.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolord.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolord.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
               libcolord.so.2()(64bit)
Error: Package: 1:control-center-3.12.0-2.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolord.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolord.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolord.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
               libcolord.so.2()(64bit)
Error: Package: 1:control-center-3.12.0-2.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolordprivate.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolordprivate.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolordprivate.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
               libcolordprivate.so.2()(64bit)
Error: Package: gnome-color-manager-3.12.0-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolordprivate.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolordprivate.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolordprivate.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
               libcolordprivate.so.2()(64bit)
Error: Package: gnome-settings-daemon-3.12.0.1-2.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolordprivate.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolordprivate.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not found
           Available: colord-libs-1.1.4-1.fc20.x86_64 (fedora)
               libcolordprivate.so.2()(64bit)
           Available: colord-libs-1.1.5-1.fc20.x86_64 (updates)
               libcolordprivate.so.2()(64bit)
Error: Package: gnome-color-manager-3.12.0-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
           Requires: libcolord.so.2()(64bit)
           Removing: colord-libs-1.1.7-1.fc20.x86_64 (@rhughes-f20-gnome-3-12-x86_64)
               libcolord.so.2()(64bit)
           Updated By: colord-libs-1.2.0-1.fc20.i686 (rhughes-f20-gnome-3-12-i386)
               Not ...
(more)
edit retag flag offensive close merge delete

Comments

im getting the same thing with the libcolord.so and the libcolordprivate.so as a requirement -_-

PhalanxA51 gravatar imagePhalanxA51 ( 2014-04-05 22:18:04 -0500 )edit

Here is what is written here:

From time to time this repo may have depsolve errors if certain libraries are in the process of being rebuilt.

So wait until everything is built, you can monitor the build tab.

remjg gravatar imageremjg ( 2014-04-06 10:51:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-04-06 10:19:55 -0500

Ahmad Samir gravatar image

The nm-connection-editor issue: is compat-gnome-bluetooth310-libs installed? it's available from the rhughes-f20-gnome-3-12-x86_64 repo.

The colord* issue: it looks like colord-1.2.0-1 is only available in rhughes-f20-gnome-3-12-i386 but not rhughes-f20-gnome-3-12-x86_64 and that's why you're seeing those colord* errors; yum is trying to install the "highest" version of colord which is only available for i686.

Either wait until colord-1.2.0 is built for x86_64 or disable the rhughes-f20-gnome-3-12-i386 repo temporarily.

edit flag offensive delete link more

Comments

FYI, colord-1.2.0 is now available in the rhughes-f20-gnome-3-12-x86_64 repo.

Ahmad Samir gravatar imageAhmad Samir ( 2014-04-08 02:42:19 -0500 )edit

Question Tools

Stats

Asked: 2014-04-05 21:07:12 -0500

Seen: 261 times

Last updated: Apr 06 '14