Ask Your Question
0

How to start gnome desktop automatically ?

asked 2014-04-03 13:20:35 -0500

Daniel Saki gravatar image

Hi! I've recently upgraded gnome to 3.12 version. after a reboot, then I couldn't access the gnome log in screen. Instead of this, A console screen (tty2) is shown and i can not log in to my new desktop. How should I fix this to start gnome automatically? Thanks for your support!

edit retag flag offensive close merge delete

Comments

Seeing as how Gnome 3.12 isn't in the Fedora 20 repos, you might want to explain how you upgraded Gnome to 3.12.

wquine gravatar imagewquine ( 2014-04-03 19:44:30 -0500 )edit

That's right. I did it as explained here

Daniel Saki gravatar imageDaniel Saki ( 2014-04-04 02:49:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-03 18:42:51 -0500

updated 2014-04-03 18:46:36 -0500

I'm assuming it worked before the upgrade; you may want to try enabling gdm.service with systemd, in case it was disabled during/after the upgrade process.

# systemctl enable gdm.service
# systemctl restart gdm.service

If, for some reason, that doesn't work, check the status of gdm by executing

# systemctl status -l gdm.service

and note any-and-all error messages that could help you narrow down the problem and lead you to a solution.

For further details on systemd, please see fedora's wiki page as well as some useful links for troubleshooting at the bottom of that page.

edit flag offensive delete link more

Comments

Thank you so much, IL Mostro! As you've said it before, I enabled the gdm.service and then restrated it to log into my gnome desktop. Now when I attempt to get the gnome desktop Version, it replies "Do you want to install gnome package?"
What should I do right now? Before enabling and restarting the gdm.service I removed rhughes--f20-gnome-3-12 repository in order to get back to 3.10 version of gnome.

Daniel Saki gravatar imageDaniel Saki ( 2014-04-04 03:10:53 -0500 )edit

glad to hear it; you should be able to get back to normal after removing the external repository and correctly updating/upgrading the packages from the official fedora repos. Please accept the answer to close this question and mark it as "solved" if that indeed resolves your issue.

ILMostro gravatar imageILMostro ( 2014-04-04 12:06:19 -0500 )edit

the gnome-desktop3 package, in particular should help you get back to a working gnome desktop environment. However, as noted in other comments, that version is not 3.12; it's 3.10.2.

# dnf install gnome-desktop3
ILMostro gravatar imageILMostro ( 2014-04-04 12:09:23 -0500 )edit

Thanks alot! It's all Done!

Daniel Saki gravatar imageDaniel Saki ( 2014-04-04 12:38:28 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-03 13:20:35 -0500

Seen: 14,536 times

Last updated: Apr 03 '14