Ask Your Question
0

How to fix this error in Monodevelop? Could not open port for debugger. Another process may be using the port

asked 2014-03-21 09:50:48 -0500

updated 2014-09-12 21:00:05 -0500

mether gravatar image

I've installed fedora 20 x86_64 on two computers in the last days, and I'm getting this error on both computers.

In Monodevelop when I try to debug the project I get this error: "Could not open port for debugger. Another process may be using the port".

I can't find anything about it on google. How can this happen on two separate computers? I filed it as a bug, at Monodevelop.

I've tried to check the port:

sudo lsof -i | grep LISTEN
[sudo] password for kristjan: 
rpcbind    657      rpc    9u  IPv4  13198      0t0  TCP *:sunrpc (LISTEN)
rpcbind    657      rpc   12u  IPv6  13201      0t0  TCP *:sunrpc (LISTEN)
sshd      1075     root    3u  IPv4  19748      0t0  TCP *:ssh (LISTEN)
sshd      1075     root    4u  IPv6  19750      0t0  TCP *:ssh (LISTEN)
rpc.statd 1081  rpcuser    9u  IPv4  19286      0t0  TCP *:39758 (LISTEN)
rpc.statd 1081  rpcuser   11u  IPv6  19290      0t0  TCP *:59428 (LISTEN)
dnsmasq   1371   nobody    7u  IPv4  22809      0t0  TCP SERVER:domain (LISTEN)
cupsd     1880     root   10u  IPv6  25043      0t0  TCP localhost:ipp (LISTEN)
cupsd     1880     root   11u  IPv4  25044      0t0  TCP localhost:ipp (LISTEN)

EDIT: I installed the KDE environment on my computer and now have the latest version of Monodevelop and it's working. I think I read somewhere that the issue is a bug in Gnome, because Gnome deleted a variable that tells Monodevelop something about the gnome environment.

edit retag flag offensive close merge delete

Comments

Are you using the monodevelop distributed by Fedora? When the error appears (at monodevelop start, or doing something else)? Is monodevelop running currently? netstat -atp | grep $(pidof monodevelop)

marcindulak gravatar imagemarcindulak ( 2014-03-21 11:06:49 -0500 )edit

@marcindulak Yes it is the package from the fedora 20 repo, (yum install monodevelop)

somethingSomething gravatar imagesomethingSomething ( 2014-03-21 12:55:06 -0500 )edit

What about the other questions?

marcindulak gravatar imagemarcindulak ( 2014-03-21 13:30:37 -0500 )edit
1

Bug ID: https://bugzilla.xamarin.com/show_bug.cgi?id=18514 . I don't experience any problems running or debugging the first example from http://mono-project.com/Mono_Basics . Reinstall monodevelop, getting rid of any personal settings: su -c "yum remove monodevelop"; rm -rf ~/.config/MonoDevelop* ~/.local/share/MonoDevelop* ~/.cache/MonoDevelop*; su -c "yum install monodevelop-debugger-gdb": does the HelloWorld work for you?

marcindulak gravatar imagemarcindulak ( 2014-03-21 15:59:52 -0500 )edit

It doesn't work. Same problem.

somethingSomething gravatar imagesomethingSomething ( 2014-03-21 16:57:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-22 14:32:03 -0500

Kayvan gravatar image

This is due to a recent gnome-terminal change. Recent gnome-terminal no longer accepts the --disable-factory argument.

Install the xterm package, then in a gnome-terminal session do the following:

$ unset GNOME_DESKTOP_SESSION_ID 
$ monodevelop

This will cause monodevelop to use xterm as its external terminal and all should be well.

edit flag offensive delete link more

Comments

This works :D But only via terminal Coulfn't this be made persistent so monodevelop could be launhed from launcher than the terminal ?

panchtatvam gravatar imagepanchtatvam ( 2014-06-30 07:06:23 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-03-21 09:50:48 -0500

Seen: 3,084 times

Last updated: Apr 22 '14