Ask Your Question
0

installed eclipse via yum and cannot start it?

asked 2014-03-16 04:16:27 -0500

flebber gravatar image

i install eclipse via yum

sudo yum install eclipse

(1/3): java-1.7.0-openjdk-javadoc-1.7.0.60-2.4.5.1.fc20.no | 14 MB 00:31 (2/3): eclipse-jdt-4.3.1-11.fc20.x86_64.rpm
| 20 MB 00:44 (3/3): eclipse-pde-4.3.1-11.fc20.x86_64.rpm
| 86 MB 01:41
-------------------------------------------------------------------------------- Total
1.2 MB/s | 120 MB 01:41 Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : 1:java-1.7.0-openjdk-javadoc-1.7.0.60-2.4.5.1.fc20.noarch 1/3 Installing : 1:eclipse-jdt-4.3.1-11.fc20.x86_64
2/3 Installing : 1:eclipse-pde-4.3.1-11.fc20.x86_64
3/3 Verifying : 1:eclipse-pde-4.3.1-11.fc20.x86_64
1/3 Verifying : 1:eclipse-jdt-4.3.1-11.fc20.x86_64
2/3 Verifying : 1:java-1.7.0-openjdk-javadoc-1.7.0.60-2.4.5.1.fc20.noarch 3/3

Installed: eclipse-pde.x86_64 1:4.3.1-11.fc20

Dependency Installed:
eclipse-jdt.x86_64 1:4.3.1-11.fc20
java-1.7.0-openjdk-javadoc.noarch 1:1.7.0.60-2.4.5.1.fc20

But when i go to start eclipse nothing

sayth@sayth ~$ eclipse bash: eclipse: command not found... sayth@sayth ~$ eclipse-pde bash: eclipse-pde: command not found.

How do i get eclipse to work using fedora's package versions

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-16 05:47:35 -0500

TenaliRaman gravatar image

I am actually surprised that only three packages were installed when you did yum install! There are usually around 100 packages that get installed when you do that, assuming the other packages were not installed as part of dependencies to other packages.

Regardless, I don't see some critical packages like eclipse-platform, eclipse-equinox-osgi, eclipse-ecf-core, eclipse-emf-core, etc. Are you sure eclipse is properly installed in your system? At the very least, eclipse-platform is essential!

edit flag offensive delete link more

Comments

@Tenali Raman No luck there its already installed apparently sayth@sayth ~$ sudo yum install eclipse-platform [sudo] password for sayth: Loaded plugins: langpacks, refresh-packagekit Package 1:eclipse-platform-4.3.1-11.fc20.x86_64 already installed and latest version Nothing to do

flebber gravatar imageflebber ( 2014-03-16 06:04:11 -0500 )edit

solved just reintalled it. Must been a dodgy install sudo yum reinstall eclipse-platform

flebber gravatar imageflebber ( 2014-03-16 06:08:17 -0500 )edit

Good :-) I guess happy programming then :P

TenaliRaman gravatar imageTenaliRaman ( 2014-03-16 06:20:09 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-16 04:16:27 -0500

Seen: 667 times

Last updated: Mar 16 '14