Ask Your Question
1

Flash player don't work on local files.

asked 2014-03-14 05:27:27 -0500

Lucas_Novais gravatar image

updated 2014-03-14 05:31:29 -0500

After I installed Fedora 20 on my new notebook all the flash player files (swf) that I have don't work on any web browser. When I try open any swf on browsers, Chrome, Chromium, or Firefox they appear as Download. I tried everything that I know already, and read a lot of topics of people with similar problem. I can play flash from web, like youtube or even swf on a server, but can't play them with File protocol...

In one of my searches for a solution I found some people with mime types problem. I tried modify this but not worked.

Some people told me about gnash, but I have graphical bugs on 90% of my swf, thus this was not a solution for my problem.

Anyone had same problem?

Sorry for bad english, and thanks for the attention.

edit retag flag offensive close merge delete

Comments

Does this work: cd /tmp; wget http://samples.mplayerhq.hu/SWF/test.swf; firefox test.swf ? How have you installed flash-plugin? See https://ask.fedoraproject.org/en/question/27697/how-can-i-allow-flash-player-on-firefox/

marcindulak gravatar imagemarcindulak ( 2014-03-14 05:41:41 -0500 )edit

Not work, appear was download. Yes my flash-plugin is installed and working.

If I copy your url and past on my firefox/chrome they can play, but downloading this and playing with file protocol don't work.

Lucas_Novais gravatar imageLucas_Novais ( 2014-03-14 05:59:20 -0500 )edit

cd /tmp; su -c "setenforce 0"; firefox file:///tmp/test.swf; su -c "setenforce 1"?

marcindulak gravatar imagemarcindulak ( 2014-03-14 07:21:06 -0500 )edit

Worked, now I can play SWF with firefox, but only as root. That is enough for me. Thank you!

Lucas_Novais gravatar imageLucas_Novais ( 2014-03-14 08:07:09 -0500 )edit
2

Don't play flash as root.

marcindulak gravatar imagemarcindulak ( 2014-03-14 10:07:25 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-03-14 07:26:02 -0500

marcindulak gravatar image

See https://bugzilla.redhat.com/show_bug.cgi?id=858328 :

su -c "setsebool -P unconfined_mozilla_plugin_transition 0"
edit flag offensive delete link more

Comments

Worked, now I can play SWF with firefox as root. Can't use google-chrome and firefox as normal user, that is enough for me. I appreciate your help, thank you.

Lucas_Novais gravatar imageLucas_Novais ( 2014-03-14 08:09:07 -0500 )edit

Then your problem is a different one (there could be much more about SELinux here) - you need to provide any errors that appear on the screen when launching firefox and also look /var/log/messages. I see for example that SELinux on Fedora 20 blocks all if firefox is started remotely over an ssh session: firefox http://samples.mplayerhq.hu/SWF/test.swf, firefox http://localhost/test.swf (apache) and firefox file:///tmp/test.swf. Fedora 19 - firefox plays swf fine over ssh.

marcindulak gravatar imagemarcindulak ( 2014-03-14 10:33:24 -0500 )edit

Sorry for the delay, I was working, away from my notebook. Okay, when I open as normal user with firefox, even with "setenforce 0" and then "setenforce 1" firefox opens Download dialog as ever, and nothing happens with SELinux, and no extra lines on /var/log/messages

Then I tried open as root, the flash played well, SELinux doesn't displayed any errors, and I get this extra lines on /var/log/messages; (next comment)

Lucas_Novais gravatar imageLucas_Novais ( 2014-03-14 17:47:17 -0500 )edit

localhost dbus-daemon: dbus[783]: avc: received setenforce notice (enforcing=1)

Mar 14 19:38:46 localhost dbus[3978]: avc: received setenforce notice (enforcing=1)

Mar 14 19:38:46 localhost dbus[1843]: avc: received setenforce notice (enforcing=1)

Mar 14 19:38:47 localhost dbus[2041]: avc: received setenforce notice (enforcing=1)

Mar 14 19:38:47 localhost dbus[783]: avc: received setenforce notice (enforcing=1)

Mar 14 19:38:47 localhost dbus-daemon: dbus[783]: [system] Reloaded configuration

Mar 14 19:38:47 localhost dbus[783]: [system] Reloaded configuration

Lucas_Novais gravatar imageLucas_Novais ( 2014-03-14 17:48:08 -0500 )edit

What is the output of rpm -q flash-plugin? /var/log/messages just show that you are issuing setenforce 1 (enable SELinux). setenforce 0 disables SELinux (do that only temporarily - that's why you do setenforce 1 after testing the influence of SELinux). You mention that no browser plays swf files - that's surprising - Chrome uses it's own flash plugin.

marcindulak gravatar imagemarcindulak ( 2014-03-15 05:53:55 -0500 )edit
2

answered 2014-03-14 08:01:10 -0500

woopwoop gravatar image

updated 2014-03-14 08:04:28 -0500

Assuming you have Flash Player installed and configured correctly -

Because of restrictions implied by browsers for security (sandboxing), some Javascript and Flash content cannot be run locally, and must be run from a server.

The problem presents when accessing content through the file:// protocol; accessing files through http:// (thus from a server, whether local or not) should make a difference.

I hope this helps you.

Edit: TL;DR: install a local web server and run it from there.

Edit 2: if it is a 3rd party SWF, it may be required to run from its originating domain.

edit flag offensive delete link more

Comments

Can you provide a link to this information?

marcindulak gravatar imagemarcindulak ( 2014-03-14 10:22:52 -0500 )edit

Adobe on Sandboxing in Flash and Air: http://help.adobe.com/en_US/as3/dev/WS5b3ccc516d4fbf351e63e3d118a9b90204-7e3f.html

Example of the sigh-factor concerning local javascript development through the file: protocol: http://devproconnections.com/javascript/working-file-protocol-google-chrome-ie-and-firefox-browsers

woopwoop gravatar imagewoopwoop ( 2014-03-14 11:41:28 -0500 )edit

It's interesting that despite the links claiming there should be limitations on file:// - on Fedora 20 it's SELinux that handles that, and apparently only in some cases (firefox over ssh with nfs $HOME, ...). Maybe the information above is entirely Windows related? You look familiar with the subject - would you mind investigating this a bit further?

marcindulak gravatar imagemarcindulak ( 2014-03-14 12:22:00 -0500 )edit

AFAIK, sandboxing is not always enabled when SELinux is installed. Also, some setups may circumvent the functionality because of its configuration. If suspicious behavior is detected in a SELinux sandbox, the user will be notified. Concerning the handling of the file protocol specifically, I don't think there's explicit SELinux involvement there, seeing the browser itself simply reads the file system with its own access restrictions when something is accesses through file: and it tries to protect the system as independent as possible (and thus enforcing specific restrictions for local files).

woopwoop gravatar imagewoopwoop ( 2014-03-18 19:11:36 -0500 )edit

Addendum: Internet Explorer's Security settings are quite explicit on allowing/blocking local file content, in contrast to others.

Some reading related to SELinux sandboxes: (some documents are from a couple of years ago, when the sandboxing in SELinux and using it was becoming a pragmatic inevitability):

https://stomp.colorado.edu/blog/blog/2010/09/21/on-selinux-sandboxes/

https://lists.fedoraproject.org/pipermail/users/2011-October/405943.html

https://www.linux.com/learn/tutorials/382226-run-applications-in-secure-sandboxes-with-selinux

woopwoop gravatar imagewoopwoop ( 2014-03-18 19:14:47 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-14 05:27:27 -0500

Seen: 4,443 times

Last updated: Jun 21 '14