Ask Your Question
-1

BlueJ not working

asked 2014-03-09 13:04:54 -0500

Fred2010 gravatar image

updated 2014-03-09 17:28:27 -0500

mether gravatar image

I cannot get BlueJ (version 3.1.1) to work on Fedora 20.

Here is the error message from BlueJ,

/* ***[ BlueJ: Error ] *****

BlueJ was unable to create a virtual machine (VM) to execute projects. This is a serious problem -- you will not be able to create objects or execute methods without solving it. Often this is caused by overly restrictive firewall settings. Please see http://www.bluej.org/help/faq.html#socket-exc for more information

  • ***[ END: BlueJ: Error ] ***** */

This software was not installed using the "Software" app on Fedora. If BlueJ was listed there I definitely would have done that, since I'm aware that gives me more assurance that the software will work.

Any help in getting this to work will be appreciated. Thanks in advance.

Fred Richard

PS: Here is the contents of my BlueJ error log,

/* ***[ BlueJ: bluej-debuglog.txt ] *****

BlueJ run started: Sun Mar 09 12:54:36 EDT 2014 BlueJ version 3.1.1 Java version 1.7.0_51 Virtual machine: OpenJDK 64-Bit Server VM 24.51-b03 (Oracle Corporation) Running on: Linux 3.13.5-200.fc20.x86_64 (amd64)

Java Home: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.5.1.fc20.x86_64/jre

Opening project: /home/fred/Desktop/Hello 1394384078321: Listening for JDWP connection on address: 127.0.0.1:48085 Connected to debug VM via dt_socket transport... 1394384079462: Failed to connect to debug VM. Reasons follow: dt_socket transport: com.sun.jdi.VMDisconnectedException at bluej.debugger.jdi.VMReference.serverThreadStartWait(VMReference.java:1613) at bluej.debugger.jdi.VMReference.waitForStartup(VMReference.java:546) at bluej.debugger.jdi.VMReference.localhostSocketLaunch(VMReference.java:341) at bluej.debugger.jdi.VMReference.<init>(VMReference.java:530) at bluej.debugger.jdi.JdiDebugger$MachineLoaderThread.run(JdiDebugger.java:1090) Commencing network test... Local host address = 127.0.0.1 Local host ip = 127.0.0.1 Addresses for 'localhost': -> 127.0.0.1 (end of list). Creating unbound server socket... Successful. Creating server socket bound to 127.0.0.1... Successful. Attempting to connect to 127.0.0.1:48004 with NO_PROXY... Successful. Attempting to connect to 127.0.0.1:48004... Successful. Creating server socket bound to 0:0:0:0:0:0:0:1... Successful. Attempting to connect to 0:0:0:0:0:0:0:1:57549 with NO_PROXY... Successful. Attempting to connect to 0:0:0:0:0:0:0:1:57549... Successful. Network test complete.</init>

/* ***[ END: BlueJ: bluej-debuglog.txt ] *****

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-03-11 06:39:31 -0500

Fred2010 gravatar image

I have resolved this issue.

I considered that perhaps the problem was the JDK. I never installed the Sun/Oracle JDK, instead keeping the default version of java from Fedora (OpenJRE and OpenJDK).

So, I installed the one from Oracle, and followed instructions found online for using the alternatives Linux system for making the Oracle JRE and JDK the default. I then opened the BlueJ IDE, but it still failed. I inspected the config on BlueJ and saw that it was still using OpenJDK Java. On the Windows version of BlueJ it's pretty easy to set one's preference of JDK, but I couldn't find a compariable method here so I deleted the local install of BlueJ, re-installed, and it is now working. The newly installed version is using the Sun/Oracle JDK (check using the menu Help>About BlueJ).

edit flag offensive delete link more
0

answered 2014-04-11 19:53:20 -0500

Joan Vidal gravatar image

updated 2014-04-11 20:08:56 -0500

1) First remove all bluej

I use..

sudo updatedb

locate bluej

and "rm"

2) Download and Install jdk 8 from oracle

http://www.bluej.org/index.html

Install jdk8 with jdk-8-linux-x64.rpm

3) And ..... change jre:

  • first locate your jre

sudo ls /usr/java/jdk1.8.0/jre/bin/

ls /usr/bin/java

  • Second Assign alternatives

sudo alternatives --install /usr/bin/java java /usr/java/jdk1.8.0/jre/bin/java 2

sudo alternatives --config java

4) Install bluej again

java -version

java -jar bluej-311.jar

edit flag offensive delete link more

Comments

Thank you so much! I had the same problem. For me worked the command: sudo alternatives --install /usr/bin/java java /usr/java/jdk1.8.0_05/jre/bin/java 2 because I downloaded the newer version 1.8.0_(number of version).

drilloman gravatar imagedrilloman ( 2014-07-01 05:58:25 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-09 13:04:54 -0500

Seen: 2,382 times

Last updated: Apr 11 '14