Ask Your Question
0

VNC server on Fedora 19 - LXDE - get empty desktop with small Grey panel

asked 2014-03-09 08:48:38 -0500

Alexis Dacquay gravatar image

updated 2014-03-09 17:26:33 -0500

mether gravatar image

Fedora 19, with LXDE installed tigerVNC server (most packages) with yum I opened the firewall I set up vncserver password, tried few sessions (:1, :2 ,etc) Sessions establishes but I get an empty desktop/screen with a grey panel in a corner, that lists 3 check boxes . [v] Accept clipboard from viewers [v] Send clipboard to viewers [v] Send primary selection to viewers

I saw this similar issue on older Linuxs, with other distributions, but can't find something that works for me. No error in the logs except something related to Xkeyboard:

*the XKEYBOARD keymap compiler (xkbcomp) reports:

Internal error: Could not resolve keysym XF86AudioMicMute Errors from xkbcomp are not fatal to the X server*

I tried different other xstarts, such as startlxde &, lxterminal, /usr/bin/lxsession -s LXDE, etc

I've got no idea how to troubleshoot. I can't find any tip for anything to install or correct scripts I would rather not have to install Gnome (slow machine + remote)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-11 05:49:14 -0500

cobra gravatar image

When your vnc server session starts it runs files in your ~/.vnc/xstartup file. If you have lxde correctly installed, it should be safe to set the file to contain just:

startlxde

Note - no '&' at the end...

If that doesn't work, then it could be that lxde isn't installed properly. You could try doing yum groupinstall lxde from the command line to pick up any bits that are not installed.

Are you tied to this DE? I use XFCE on my permanent vnc server session. It's installed in a similar way, and you start it with 'starxfce'.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-03-09 08:48:38 -0500

Seen: 2,818 times

Last updated: Mar 11 '14