Ask Your Question
0

How do get the RTL8723BE wifi card working

asked 2014-03-08 09:36:32 -0500

danyule gravatar image

updated 2014-03-08 10:17:46 -0500

I have just bought a new generic i5 laptop. I thought I would try out Fedora as it looks like a good way to learn Linux. My first learning opportunity has arisen as I am struggling to get the wifi card working. When list the peripherals I find that my wifi card is a Realtek RTL8723BE:

[drice@localhost ~]$ lspci -nn
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5287] (rev 01)
03:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)

I have been googling like mad and have found out that this wifi card will not have drivers until kernel 3.15 (while I am on 3.13) see [wireless.kernel.org]](http://wireless.kernel.org/en/users/Drivers/rtl819x#Realtek_802.11n_drivers).

But I have found some driver code on git that has provided success for users using Ubuntu. So I:

  1. cloned the git directory
  2. installed gcc
  3. installed kernel-devel

When attempting make I get the following:

[root@localhost rtl8723be]# make
make -C /lib/modules/3.13.5-202.fc20.x86_64/build M=/home/drice/Documents/git/rtl8723be modules
make[1]: Entering directory `/usr/src/kernels/3.13.5-202.fc20.x86_64'
  CC [M]  /home/drice/Documents/git/rtl8723be/base.o
  CC [M]  /home/drice/Documents/git/rtl8723be/rc.o
  CC [M]  /home/drice/Documents/git/rtl8723be/debug.o
  CC [M]  /home/drice/Documents/git/rtl8723be/regd.o
In file included from /home/drice/Documents/git/rtl8723be/regd.c:31:0:
/home/drice/Documents/git/rtl8723be/regd.c: In function ‘_rtl_reg_apply_beaconing_flags’:
/home/drice/Documents/git/rtl8723be/regd.h:37:32: error: ‘IEEE80211_CHAN_NO_IR’ undeclared (first use in this function)
 #define IEEE80211_CHAN_NO_IBSS IEEE80211_CHAN_NO_IR
                                ^
/home/drice/Documents/git/rtl8723be/regd.c:200:20: note: in expansion of macro ‘IEEE80211_CHAN_NO_IBSS’
      ch->flags &= ~IEEE80211_CHAN_NO_IBSS;
                    ^
/home/drice/Documents/git/rtl8723be/regd.h:37:32: note: each undeclared identifier is reported only once for each function it appears in
 #define IEEE80211_CHAN_NO_IBSS IEEE80211_CHAN_NO_IR
                                ^
/home/drice/Documents/git/rtl8723be/regd.c:200:20: note: in expansion of macro ‘IEEE80211_CHAN_NO_IBSS’
      ch->flags &= ~IEEE80211_CHAN_NO_IBSS;
                    ^
/home/drice/Documents/git/rtl8723be/regd.c: In function ‘_rtl_reg_apply_active_scan_flags’:
/home/drice/Documents/git/rtl8723be/regd.h:34:37: error: ‘IEEE80211_CHAN_NO_IR’ undeclared (first use in this function)
 #define IEEE80211_CHAN_PASSIVE_SCAN IEEE80211_CHAN_NO_IR
                                     ^
/home/drice/Documents/git/rtl8723be/regd.c:237:19: note: in expansion of macro ‘IEEE80211_CHAN_PASSIVE_SCAN’
   if (ch->flags & IEEE80211_CHAN_PASSIVE_SCAN)
                   ^
/home/drice/Documents/git/rtl8723be/regd.c: In function ‘_rtl_reg_apply_radar_flags’:
/home/drice/Documents/git/rtl8723be/regd.h:37:32: error: ‘IEEE80211_CHAN_NO_IR’ undeclared (first use in this function)
 #define IEEE80211_CHAN_NO_IBSS IEEE80211_CHAN_NO_IR
                                ^
/home/drice/Documents/git/rtl8723be/regd.c:312:8: note: in expansion of macro ‘IEEE80211_CHAN_NO_IBSS’
        IEEE80211_CHAN_NO_IBSS |
        ^
/home/drice/Documents/git/rtl8723be/regd.c: In function ‘_rtl_regd_init_wiphy’:
/home/drice/Documents/git/rtl8723be/regd.h:40:38: error: ‘REGULATORY_CUSTOM_REG’ undeclared (first use in this function)
 #define WIPHY_FLAG_CUSTOM_REGULATORY REGULATORY_CUSTOM_REG
                                      ^
/home/drice/Documents/git/rtl8723be/regd.c:410:18: note: in ...
(more)
edit retag flag offensive close merge delete

Comments

Thank you very much marcindulak! That did the trick. Since you solved this how I do I give you the credit and mark answered?

danyule gravatar imagedanyule ( 2014-03-08 10:18:07 -0500 )edit

OK - i just googled, but let's mark it as correct answer.

marcindulak gravatar imagemarcindulak ( 2014-03-08 10:23:08 -0500 )edit

do you have any solution... i have the same problem I'm search long time for a solution , i had no answer :(

fedora new gravatar imagefedora new ( 2014-04-15 03:57:08 -0500 )edit

3 Answers

Sort by » oldest newest most voted
-1

answered 2014-03-08 10:03:05 -0500

marcindulak gravatar image

updated 2014-03-08 12:14:07 -0500

http://bit.ly/1kEju9E - askubuntu says you need to get an earlier git version of https://github.com/lwfinger/rtl8723be

edit flag offensive delete link more

Comments

-1. LGMTFY isn't a "good answer" - and I wanted the link to lead to something interesting, because the version of git used to clone a repo should not affect the contents of the repo or it's ability to function.

randomuser gravatar imagerandomuser ( 2014-03-08 10:49:33 -0500 )edit

I'm not talking about a version of git - that was obvious to the @danyule . Now a more explicit answer

marcindulak gravatar imagemarcindulak ( 2014-03-08 12:13:11 -0500 )edit
0

answered 2014-04-15 03:48:59 -0500

do you have any idea I have same make error plz help me

edit flag offensive delete link more
0

answered 2014-09-14 14:54:53 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Ok, there are still bugs with the rtl8723be on kernel 3.15.x.

I found the perfect fix with no disconnections or anything.

Go here and download and install all 3 debs for 32 or 64 bit:

http://ubuntuhandbook.org/index.php/2014/08/install-upgrade-linux-kernel-3-16/

Choose 32-bit or 64-bit (depending on which system you installed)

reboot into the new 3.16.x

Run:

apt-get -f autoremove

Next run:

dpkg --list | grep linux-image

apt-get purge (Old Kernel):

exp: apt-get purge linux-image-3.14-kali1-amd64

or apt-get purge linux-image-3.14

Once you removed old kernel run:

update-grub2

After you are done, reboot. The wireless drivers will be 100% working and no data drops like in 3.15.x kernel!

& drivers are pre-installed in the new kernel!

edit flag offensive delete link more

Comments

This is not going to help for a person using Fedora as those above commands only be working on Debian based distributions.

pnemade gravatar imagepnemade ( 2014-09-14 22:21:05 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-03-08 09:36:32 -0500

Seen: 14,314 times

Last updated: Sep 14 '14