Ask Your Question
0

unable install NVIDIA driver Fedora 20

asked 2014-03-06 14:24:32 -0500

kentiq13 gravatar image

updated 2014-03-06 14:52:25 -0500

mether gravatar image

Fedora 20 x32 MATE 1.6 Driver - NVIDIA-Linux-x86-304.43.run сыпеться ошибка ERROR: Unable to find the kernel source tree for the currently running kernel.

lsmod | grep nouveau пустой т е nouveau драйвер я выгрузил

/var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log' creation time: Thu Mar 6 22:08:09 2014 installer version: 304.43

PATH: /sbin:/bin:/usr/sbin:/usr/bin

nvidia-installer command line: ./nvidia-installer

Using: nvidia-installer ncurses user interface -> Tagging shared libraries with chcon -t textrel_shlib_t. -> License accepted. -> Installing NVIDIA driver version 304.43. -> Performing CC sanity check with CC="cc". -> Performing CC version check with CC="cc". ERROR: Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' command line option.

/etc/modprobe.d/blacklist.conf blacklist vga16fb blacklist nouveau blacklist rivafb blacklist nvidiafb blacklist rivatv

Делал по этому ману и застрял на установке драйверов:

1) Blacklist the nouveau driver: Add below line to /etc/modprobe.d/blacklist.conf file blacklist nouveau 2) Rebuild the initramfs image file using dracut: * Backup the initramfs file $ sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).img.bak * Rebuild the initramfs file $ sudo dracut -v /boot/initramfs-$(uname -r).img $(uname -r) 3) Reboot the system to runlevel 3 (without graphics) 4) Check that nouveau driver is not loaded $ lsmod | grep nouveau 5) Run the NVidia driver package $ sudo ./NVIDIA-Linux-x86_64-195.36.15-pkg2.run Above command will create xorg.conf file in /etc/X11 directory which is responsible to use NVidia driver in X. 6) Restart the system and NVidia driver will be used now.

[kentiq13@localhost ~]$ sudo yum install kernel-devel kernel-headers gcc [sudo] password for kentiq13: Loaded plugins: langpacks Package kernel-headers-3.13.5-202.fc20.i686 already installed and latest version Package gcc-4.8.2-7.fc20.i686 already installed and latest version Nothing to do

uname -a Linux localhost.localdomain 3.11.10-301.fc20.i686 #1 SMP Thu Dec 5 14:21:31 UTC 2013 i686 i686 i386 GNU/Linux dmitrenko1985

Please HELP!!!!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-06 15:11:37 -0500

sideburns gravatar image

Uninstall that .run file and get rid of it completely, because if you use it, you'll have to go through this again every time there's an update to the kernel. Instead, follow the instructions here: http://forums.fedoraforum.org/showthread.php?t=204752 Yes, I know the title only lists Fedora 14, 15 and 16 in the title, but they work just as well on F 20 as they did back then. And, once you've done this, you'll never have to do it again. Personally, I'd suggest following the akmod path instead of the kmod path because the kmod sometimes comes out as much as a day later than the new kernel, and the akmod will build a new driver for the kernel at boot if needed. Of course, if you don't update daily (as I do) that might not be a problem for you.

edit flag offensive delete link more
0

answered 2014-03-18 07:22:24 -0500

panchtatvam gravatar image

I suggest to first check if your NVIDIA has optimus technology and if so use the Bumblebee project. Check my answer here on a similar question: https://ask.fedoraproject.org/en/question/34572/fedora-19-stopped-working-after-nvidia-drivers/?answer=43581#post-id-43581

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-03-06 14:24:32 -0500

Seen: 7,738 times

Last updated: Mar 18 '14