Ask Your Question
0

Bumblebee works but ineffective after upgrading to Fedora 20

asked 2014-03-04 02:45:26 -0500

riyadhlinux gravatar image

updated 2014-03-04 02:45:50 -0500

I use a nvidia card with nouveau. I also use Bumblebee to regulate its use. It worked nicely and the desktop graphics were normal, until I upgraded to Fedora 20. After upgrading, Bumblebee is still working, but the card is always on, hot and consumes lots of power.

GNOME classical mode does not help either, and the card is turned on when GDM is started, before the standard or the classical session is chosen.

Is there a way to turn off maximum hardware acceleration in Fedora 20 GNOME?

uname -a
Linux localhost.localdomain 3.13.5-200.fc20.x86_64 #1 SMP Mon Feb 24 16:51:35 UTC 2014 x86_64 x86_64 x86_64  GNU/Linux
edit retag flag offensive close merge delete

Comments

Do you use bumblebee to run programs, or just to turn off the nvidia card?

QuLogic gravatar imageQuLogic ( 2014-03-07 01:50:57 -0500 )edit

I only use it to turn off the nvidia card.

riyadhlinux gravatar imageriyadhlinux ( 2014-03-08 02:28:08 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-03-09 19:21:32 -0500

QuLogic gravatar image

updated 2014-03-11 20:36:56 -0500

If all you want to do is turn off the card, I'm not sure if bumblebee is necessary. This may depend on which cards are supported by the driver, but you can try this:

  • Remove bumblebee
  • cat /sys/kernel/debug/vgaswitcheroo/switch which should produce something like:

    0:IGD:+:Pwr:0000:00:02.0

    1:DIS: :DynOff:0000:01:00.0

If the nvidia card (DIS) is not DynOff or OFF, then do echo OFF > /sys/kernel/debug/vgaswitcheroo/switch.

You will need to be root to access that file, so use sudo. If that works, then you can add a script to run at startup to do it.

Edit: To stop X from using the card, you can add a little config fragment to use the intel graphics only. Create the file /etc/X11/xorg.conf.d/20-intel-only.conf and place the following in it:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
EndSection
edit flag offensive delete link more

Comments

Yes, I think this is good enough.

cat /sys/kernel/debug/vgaswitcheroo/switch had the following output:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynPwr:0000:01:00.0

But echo OFF > /sys/kernel/debug/vgaswitcheroo/switch did not change that.

riyadhlinux gravatar imageriyadhlinux ( 2014-03-10 14:16:20 -0500 )edit

I believe DynPwr means that something is using the card. Have you checked that X (for example) is not initializing it? Check /var/log/Xorg.0.log.

QuLogic gravatar imageQuLogic ( 2014-03-10 14:54:44 -0500 )edit

Here is the nouveau-related output of Xorg.0.log:

http://pastebin.com/hnR6rVrV

riyadhlinux gravatar imageriyadhlinux ( 2014-03-11 02:15:03 -0500 )edit

I've added some instructions for disabling X's use of the second card.

QuLogic gravatar imageQuLogic ( 2014-03-11 20:37:15 -0500 )edit

It worked. Thanks a lot!

riyadhlinux gravatar imageriyadhlinux ( 2014-03-12 07:24:31 -0500 )edit
0

answered 2014-03-10 18:04:58 -0500

deusdara gravatar image

Hi

Please see that thread

Bumblebee with the NVIDIA proprietary drivers

https://fedoraproject.org/wiki/Bumblebee#Bumblebee_with_the_NVIDIA_proprietary_drivers

edit flag offensive delete link more

Comments

The free software nouveau driver used to work just with Bumblebee find in Fedora 19. What has changed?

riyadhlinux gravatar imageriyadhlinux ( 2014-03-11 02:15:57 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-03-04 02:45:26 -0500

Seen: 553 times

Last updated: Mar 11 '14