Ask Your Question
2

How do I enable shortcut icons for the GNOME desktop?

asked 2014-03-01 14:58:33 -0500

OvidiuN gravatar image

updated 2014-03-03 16:21:04 -0500

mether gravatar image

I've just installed Fedora 20 and I tried to put some files on the desktop and it doesn't work. I can use all the things on the bar but just can't figure out how to put some shortcuts on desktop in the "classical way".

I've tried to put a file in ~/Desktop but still doesn't appear.

Any ideas?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
3

answered 2014-03-01 18:20:31 -0500

mether gravatar image

GNOME doesn't do this by default. However you can use GNOME Tweak Tool to enable and customize it. Use GNOME Software to install it or do the following

sudo yum install gnome-tweak-tool

Go to the "Desktop" tab and select "Icons on Desktop" and select the shortcuts you want.

edit flag offensive delete link more
1

answered 2014-03-01 16:37:57 -0500

keramidas gravatar image

Fedora uses Gnome 3 as a Desktop Enviroment. Gnome 3 does not support putting files on the Desktop the "traditional way".

edit flag offensive delete link more
0

answered 2014-03-04 08:32:26 -0500

q2dg gravatar image

Yes, you can. Write a "desktop" file ( https://developer.gnome.org/integration-guide/stable/desktop-files.html.en ) and give it execution permissions

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-03-01 14:58:33 -0500

Seen: 68,846 times

Last updated: Mar 04 '14