How do I enable SNA on Intel without disabling device detection?

asked 2014-02-22 20:36:36 -0500

QuLogic gravatar image

updated 2014-02-22 20:48:14 -0500

Following the instructions here, I am able to enable SNA on Intel. This part works fine.

However, I have a laptop with both Intel and AMD cards. When I add the above configuration, then the AMD card is not detected, and its driver is not loaded.

So, how can I enable SNA without disabling device detection? If that's not possible, what's the simplest way to have both drivers load (preferably with the remaining settings auto-detected as usual)?

Before I forget,

$ rpm -q xorg-x11-server-Xorg xorg-x11-drv-intel xorg-x11-drv-ati
xorg-x11-server-Xorg-1.14.4-6.fc20.x86_64
xorg-x11-drv-intel-2.21.15-5.fc20.x86_64
xorg-x11-drv-ati-7.2.0-3.20131101git3b38701.fc20.x86_64
edit retag flag offensive close merge delete