Ask Your Question
0

Edit fstab to automount NTFS

asked 2014-02-19 21:44:41 -0500

asoap gravatar image

updated 2015-09-03 22:50:10 -0500

deadrat gravatar image

Hi guys!

I am using a dual-boot system with Windows and Fedora KDE. As Fedora can read NTFS, but Win cannot read ext4, my data is stored in NTFS.

Mounting NTFS partitions is working well, however, it requires to give the root password every day for every partition. Also, if multiple users are using my computer, they would need to know the root pass to access the data, and after finishing their work, they would need to unmount the devices to make them accessible for the others without rebooting. What I would need is a settings file that tell the computer to mount the data drives at the beginning, and provid them for every users.

I was trying to edit the fstab file to make this happen, according to the result of the mount command, but it only gave an error at the next reboot.

I heard that KDE has a tool called KFtab to easily edit the fstab file, but that program is not available in my repos, and it website was last updated in 2002... doesn't seem very trustworthy.

So, in the end, is there a way to set up the system as I want it, or it is best if I type in the root pass for mounting every day?

Thank you in advance for your answers!


UPDATE: PySDM couldn't help either. Now trying fwfstab.

edit retag flag offensive close merge delete

Comments

1

fstab fields/syntax is explained in the manual page, man fstab in terminal. Have a look there and post back if it still doesn't work for you.

Ahmad Samir gravatar imageAhmad Samir ( 2014-02-20 01:57:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-02-20 02:42:04 -0500

Glenn gravatar image

This is what I would typically use.

/dev/sda1 /windowsc ntfs-3g defaults 0 0
/dev/sda5 /windowsd ntfs-3g defaults 0 0

In fact, I have a hard disk partition that I mount at boot using the UUID of the partition.

# NTFS formatted storage disk
UUID=64634BCF0BD2AB62   /mnt/windows    ntfs-3g defaults    0 0

This has been working flawlessly for months, if not years.

edit flag offensive delete link more
0

answered 2014-02-19 22:36:18 -0500

sergiomb gravatar image
/dev/sda1 /windowsc ntfs-3g uid=500,gid=500 0 0
/dev/sda5 /windowsd ntfs-3g uid=500,gid=500 0 0

cat /var/log/rpmpkgs| grep ntfs

ntfs-3g-2013.1.13-6.fc20.x86_64.rpm
ntfsprogs-2013.1.13-6.fc20.x86_64.rpm
edit flag offensive delete link more

Comments

Specifying uid/gid bits isn't optimal; the default regular users' uid being from 1000 in recent distros. Also from the OP it seems that more than one user need access to the partitions, this will make it work for just one user (if there's a user with a uid 500).

Ahmad Samir gravatar imageAhmad Samir ( 2014-02-20 01:59:56 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-02-19 21:44:41 -0500

Seen: 15,096 times

Last updated: Feb 20 '14