Ask Your Question
0

f20: firewalld disables nfs although nfs service is enabled. [closed]

asked 2014-02-16 03:32:07 -0500

leamas gravatar image

updated 2014-02-16 07:57:39 -0500

mether gravatar image

As usual, this is probably something silly. But: on a F20 host, updated as of today, I run a nfs server. I have enabled nfs in the firewalld config:

$ sudo firewall-cmd --list-services dhcpv6-client dns http mdns mysql nfs ssh

Now, if I run showmount on a remote client:

$ showmount -e nfshost rpc mount export: RPC: Unable to receive; errno = No route to host

OTOH, if I disable the firewall:

$ showmount -e nfshost Export list for nfshost: /export.nfs4/Download 192.168.0.0/24,127.0.0.1/24>
/export.nfs4/myth 192.168.0.0/24,127.0.0.1/24 /export.nfs4 127.0.0.1/24,192.168.0.0/16

Ergo: the firewall blocks nfs although nfs is enabled.... Any hints out there?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Marc lml
close date 2014-02-16 07:18:05.237047

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-16 05:00:47 -0500

leamas gravatar image

Oops, a duplicate of https://ask.fedoraproject.org/en/question/9864/ - the solution described there works fine. Sorry for the noise

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-16 03:32:07 -0500

Seen: 1,259 times

Last updated: Feb 16 '14