Ask Your Question
2

alienware fans running

asked 2014-02-11 15:18:56 -0500

tomw-gb gravatar image

updated 2014-02-11 18:57:50 -0500

NickTux gravatar image

Installed Fedora 20 this evening onto my Alienware M17, and all is well except the fans seem to run a great deal of the time even under light load. Is there a specific setting or driver I should install to help the hardware understand it doesn't need the fans running?

Thanks for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-11 18:53:32 -0500

NickTux gravatar image

updated 2014-02-11 18:55:06 -0500

First of all you have to see the temperatures. I guess that will be high enough to keep the Fans busy all the time, but it is good to check the temperatures in order to see if the practice I'm describing here, will have any effect or not.

Install lm_sensors package in order to check the temps.

sudo yum install lm_sensors

then do a sensors search with

sudo sensors-detect

answer with the Enter key in all questions and then check the temps with

sensors

You should be able to see some temperatures now. If not, try to reboot and again apply sensors command.

There is a program in Fedora named Tuned. Click here and start reading. At my opinion, it is a very powerful as handy as well, power management program.

It comes with predefined profiles you can set easy. Do not forget to enable the systemd tuned.service in order to start on boot(reboot) of PC.

sudo systemctl enable tuned.service

If you want to check various profiles on the fly, you have to first stop the service and start it again (in order to load the new profile).

sudo systemctl stop tuned 
sudo systemctl start tuned

To list the available profiles

sudo tuned-adm list

should return something like

 Available profiles:
- balanced
- latency-performance
- powersave
- throughput-performance
- virtual-guest
- virtual-host

You can read , either on the documentation or the manual page, what these profiles are.

I can tell you that I saw a drop in CPU(s) temperatures (in my Acer Latop) about 10 degrees with lowcatency and powersave profiles, but you will find what is best for you and If you don't, then read a little more on how you can create a custom profile.

edit flag offensive delete link more

Comments

Thanks for the terrific answer. Lots of useful stuff. The original problem is much better now. The only component warm is the radion-pci-adapter. I know realise this is a general power management question really. My battery life is now 1/3 what it was under Win7 and I'm trying to track down what is consuming sho much power

tomw-gb gravatar imagetomw-gb ( 2014-02-13 18:12:55 -0500 )edit

For the radeon , do you have any additional driver installed ? (manually I mean). If not, try this command and check again the temperature su -c "echo low > /sys/class/drm/card0/device/power_profile" . Probably the graphic card is working on non-low profile, consumes lot of power.

NickTux gravatar imageNickTux ( 2014-02-14 05:25:12 -0500 )edit

no, but i'm trying to get bumblebee installed (it fails on starting the daemon). Anyway, the command you suggest results in an error that no such file exists. From the forums it seems these settings have been moved around in F20. I'm beginning to wonder if the keyboard backlight is the culprit. I can't figure out how to turn off the lighting of the keyboard. Anyway, thanks for your help!

tomw-gb gravatar imagetomw-gb ( 2014-02-14 08:21:07 -0500 )edit

You mentioned "radeon-pci-adapter" . Now you said about bumblebee, so you have Nvidia and Intel. Right ? The "radeon-pci-adapter".. how comes ?

NickTux gravatar imageNickTux ( 2014-02-14 10:20:09 -0500 )edit

Question Tools

Stats

Asked: 2014-02-11 15:18:56 -0500

Seen: 525 times

Last updated: Feb 11 '14