Ask Your Question
0

how to start a mobile broadband connection in fedora 20 [closed]

asked 2014-02-11 02:39:12 -0600

jringoot gravatar image

Until yesterday I used fedora 19, I did a smooth upgrade, alas mobile broadband is no longer available in gnome. It is still when I boot in Ubuntu 13.10 however. because I could still see, what I think are the required kernelmodules:

root@legolas ~]# lsmod | grep cdc
cdc_mbim               13176  0 
cdc_ncm                19689  1 cdc_mbim
usbnet                 41932  2 cdc_mbim,cdc_ncm
cdc_wdm                18864  1 cdc_mbim
cdc_acm                28754  0 
[root@legolas ~]#

I suspected it is probably related to the new version of gnome. So I installed KDE. I can now see the mobile broadband connection but I seem unable to find how to activate it. (BTW: I was unable to attach a screenshot of this, I get the error " rror uploading file. Please contact the site administrator. Thank you.") So how to start a mobile connection now? It is not listed in the connections widget in the menubar, I have only the wired, wirelless and VPN options there.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2016-05-25 09:27:21.055656

2 Answers

Sort by » oldest newest most voted
0

answered 2014-02-11 06:00:30 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I assume you are using a (possibly rebranded) Ericsson MBM module?

These modules implement both the NCM and MBIM protocols in a single function, meaning that the kernel has to make a choice on behalf of the user because the choice is made while selecting the appropriate driver. This is unfortunate because the kernel has no knowledge about neither userspace application support nor user preferences. The problem in your case is most likely that MBIM was selected by the kernel, but isn't yet supported by the ModemManager version you have.

But no worries. You can tell the kernel to make a different choice. The default preference is temporarily overridden by doing

 echo N >/sys/module/cdc_ncm/parameters/prefer_mbim

or more permanently changed by creating e.g. a /etc/modprobe.d/ncm.conf file with a line like this:

 options cdc_ncm prefer_mbim=N

Note that this new preference will only take effect on the next driver probe, so you will have to "unplug" and replug the modem to make it effective. And as your modem is most likely built-in, that probably means using rfkill. Or just create the file and unload/reload the drivers. Or reboot if you find that easiest. Be aware the temporary solution given above will only work with the rfkill based method.

The above should only be considered a temporary workaround. There are good reasons why you would want to use MBIM for mobile broadband devices in the future, as soon as the ModemManager support is in place. It provides a better and more standardized management protocol.

edit flag offensive delete link more

Comments

Hi Bjorn, thank you for looking in to this. I just verified, the device manager in windows (7) says it is a "Dell Wireless 5550 HSPA+ Mini-Card Modem"

jringoot gravatar imagejringoot ( 2014-02-12 16:53:01 -0600 )edit

I applied the changes you suggested and did a reboot. The changes appear applied:

[root@legolas ~]# cat /etc/modprobe.d/ncm.conf
options cdc_ncm prefer_mbim=N
[root@legolas ~]# cat /sys/module/cdc_ncm/parameters/prefer_mbim
N
[root@legolas ~]#

But still no sign of a broadband device in the networkmanager in fedora (not in gnome).

jringoot gravatar imagejringoot ( 2014-02-12 16:56:51 -0600 )edit

Then I was obviously wrong and have no idea what else could be wrong. Try looking at the ModemManager logs and/or use the mmcli command line utility to see what kind of modem MM has detected, if any.

Listing modems:

mmcli -L

Seeing details for a single modem:

mmcli -m 0
Bjørn Mork gravatar imageBjørn Mork ( 2014-02-13 03:10:38 -0600 )edit

There is apparently something wrong with the ModemManager, this is what I get when I do what you suggest:

[root@legolas ~]# mmcli -L
error: couldn't find the ModemManager process in the bus
[root@legolas ~]# yum install ModemManager
Geladen plugins: fs-snapshot, langpacks, ps, refresh-packagekit
Pakket ModemManager-1.1.0-2.git20130913.fc20.x86_64 is reeds geïnstalleerd en de meest recente versie
Niets te doen
[root@legolas ~]#
jringoot gravatar imagejringoot ( 2014-02-13 14:50:21 -0600 )edit

Other stuff:

[root@lego

las ~]# ModemManager
ModemManager[5137]: <info>  ModemManager (version 1.1.0-2.git20130913.fc20) starting...
ModemManager[5137]: <warn>  Could not acquire the 'org.freedesktop.ModemManager1' service name
ModemManager[5137]: <info>  ModemManager is shut down
[root@legolas ~]#
jringoot gravatar imagejringoot ( 2014-02-13 15:02:17 -0600 )edit
0

answered 2016-05-25 08:32:44 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

run command ModemManager & after that run mmcli -L...and your error error: couldn't find the ModemManager process in the bus sloved...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-02-11 02:39:12 -0600

Seen: 3,848 times

Last updated: May 25 '16