Ask Your Question

Can not load Lyx( and TeXmacs) on Fedora 20

asked 2014-02-10 13:54:23 -0500

sadapplelc gravatar image

updated 2014-02-11 20:51:17 -0500

FranciscoD_ gravatar image

I recently began to learn Linux via Fedora 20 and today have successfully installed the package lyx-2.0.7-2.fc20.x86_64 via the command:

yum install lyx.

But when I tried to launch it, it returned the following error message:

[root@chuanliu ~]# lyx
lyx: error while loading shared libraries: cannot open shared object file: No such file or directory

The similar message appears after I installed TeXmacs and tried to launch it.

Can anyone tell me how to resolve this problem? Let me thank you all in advance :)

My system version is Fedora 20 and I've installed texlive and updated the system in the terminal.

edit retag flag offensive close merge delete


First - don't launch applications as root. su -c "yum -y install lyx" should pull the necessary dependency (qt-x11). There have been probably some manual steps performed - try if su -c "yum clean all"su -c "yum -y reinstall lyx" helps

marcindulak gravatar imagemarcindulak ( 2014-02-10 14:17:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-02-10 21:00:52 -0500

sergiomb gravatar image

updated 2014-02-10 21:01:33 -0500


I just install lyx and is working, is strange fail to load .

First yum install lyx should install qt-x11 as dependency , is rpm internally make this kind of dependencies ...

So just left one thing , as root do:

ldconfig  -a

and try lyx again.

if it work it a little bug that we should report to package maintainers of qt-x11 to add ldconfig in rpm configuration.

edit flag offensive delete link more


+1 to filing a bug. I don't see anything in the spec that could cause this, but the maintainer would have more time to look at it.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-02-11 20:50:51 -0500 )edit

if I get one confirmation, I will

sergiomb gravatar imagesergiomb ( 2014-02-11 21:38:10 -0500 )edit

The dependency is there: rpm -q --whatprovides `rpm -q --requires lyx | grep libQtGui`: qt-x11-4.8.5-15.fc20.x86_64

marcindulak gravatar imagemarcindulak ( 2014-02-12 14:48:51 -0500 )edit


line 1179 we got : %post x11 /sbin/ldconfig

So package is correct , or at least the error has been corrected.

sergiomb gravatar imagesergiomb ( 2014-03-05 15:48:24 -0500 )edit

Question Tools


Asked: 2014-02-10 13:54:23 -0500

Seen: 584 times

Last updated: Feb 10 '14