Ask Your Question
0

Fedora 20 don't boot to desktop

asked 2014-02-03 21:38:23 -0500

Alexandre1545 gravatar image

updated 2014-02-04 13:17:04 -0500

mether gravatar image

Since an update, my Fedora don't want to boot to desktop, i've tried with all kernel. I can access a tty and connect to my user in it. I've tried to run yum update again, but I got many dependency problem with the nvidia driver from RPM Fusion (I'm using akmod). Running yum update --skip-broken is omitting glibc-headers and kernel-headers, but even with --skip-broken the update don't finish. I've tried updating using --enablerepo=updates-testing, but it don't work too.

edit retag flag offensive close merge delete

Comments

I'm currently using akmod-nvidia on F20 and am not having any dependency issues. Do you have any third-party repos other than rpmfusion, or updates-testing packages that might be causing the problem?

robatino gravatar imagerobatino ( 2014-02-03 21:41:34 -0500 )edit

I only have RPM Fusion and default Fedora repo enabled and I've got the problem before enabling updates-testing.

Alexandre1545 gravatar imageAlexandre1545 ( 2014-02-03 22:21:11 -0500 )edit

You could try running "yum list extras" to see if you have any packages installed that are not currently available in your enabled repos (other than packages which can have more than one version installed, like old kernels, which are expected). I can't think of anything else - AFAIK, there are currently no actual dependency problems between Fedora stable and rpmfusion.

Edit: You could also try "package-cleanup --problems" and "package-cleanup --dupes" to look for existing problems with your installed package set.

robatino gravatar imagerobatino ( 2014-02-03 22:38:53 -0500 )edit

You might also have to make sure you have the right version of akmod-nvidia installed for your video hardware, as described at http://rpmfusion.org/Howto/nVidia. For example, I have a GeForce 6 and have akmod-nvidia-304xx installed. I think it's possible to install the wrong one by mistake, and don't know if one could have more than one installed at the same time.

robatino gravatar imagerobatino ( 2014-02-03 22:46:55 -0500 )edit

If you have some packages from updates-testing and some not, then later disable updates-testing, your system can get in a state where dependencies don't resolve smoothly. This might be what's happening; editing your question to include the full yum command and output would help.

randomuser gravatar imagerandomuser ( 2014-02-03 23:40:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-02-04 11:15:14 -0500

As noted in the common-bugs page, this bug is resolved with an updated SELinux policy selinux-policy.noarch 0:3.12.1-117.fc20. In order to successfully resolve it, follow the instructions posted there:

setenforce 0
yum clean expire-cache
yum update selinux-policy\*
setenforce 1

Feel free to check out this thread as well on fedoraforum.org


Additionally, if for some reason your issue is still not resolved, you might have to relabel the file system like so:

# touch /.autorelabel
# reboot

NOTE: this will take some time during the boot-up process to relabel all files according to your updated SELinux policy; so, be patient during that boot-up!

edit flag offensive delete link more

Comments

But if like me, you got broken dependency, you not be able to run: yum update selinux-policy*

After "setenforce 0" and "yum clean expire-cache" I have run "package-cleanup --cleandupes" and removed package that were blocking the process or multiple packages and then with "yum distro-sync --skip-broken" I've been able to run "yum update" and set SELinux to "setenforce 1"

Alexandre1545 gravatar imageAlexandre1545 ( 2014-02-04 14:29:28 -0500 )edit
1

you can also just boot with the kernel command-line parameter selinux=0 to disable SELinux for that session; and then perform the necessary operations.

ILMostro gravatar imageILMostro ( 2014-02-04 15:13:00 -0500 )edit
0

answered 2014-02-04 04:02:43 -0500

Glenn gravatar image

This thread at Fedora Forum has been a saviour for many a NVidia user. It was originated by one of the maintainers of the Linux NVidia drivers. Maybe it will be of help to the OP.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-02-03 21:38:23 -0500

Seen: 424 times

Last updated: Feb 04 '14