Ask Your Question
3

Disk partitioning issue when trying to install Fedora 20 to dual boot with windows 8

asked 2014-02-01 19:20:46 -0600

Momo8 gravatar image

updated 2014-02-02 02:28:16 -0600

FranciscoD_ gravatar image

I am trying to install fedora 20. I have already set a separated the partition from my windows drive and created an F: drive but when i am trying to run the install it isn't showing the partition. It is showing the full drive with all the available memory. What am I doing wrong or do i need to do? Please help.

edit retag flag offensive close merge delete

Comments

Just a comment: I don't understand why people are still trying to configure Windows/Linux dual boots - that's something that made sense 10 years ago. Why not installing Linux in Hyper-V? http://www.youtube.com/watch?v=XCTmTzepDe8

marcindulak gravatar imagemarcindulak ( 2014-02-01 20:13:25 -0600 )edit
1

@marcindulak because virtual machines are not the same as a physical/real hardware ?

NickTux gravatar imageNickTux ( 2014-02-01 21:37:55 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2014-02-02 02:11:47 -0600

NickTux gravatar image

updated 2014-02-02 02:36:04 -0600

Manual partitioning procedure


First of all, disable the secure boot from UEFI configuration page. This is (almost) mandatory in order to proceed the dual boot without further problems.

Download a 64bit .iso image of the latest stable Fedora desktop edition.

From within Windows create a space - a partition - where you will install Fedora.

Create a bootable USB stick. You can use a tool like unetbootin (for Windows).

Make sure that Windows 8 will power off properly. Don't hibernate, or suspend..etc. If you hibernate, the disk will not be available for installation.

Start the PC and boot from the USB stick. The installer should come up. Proceed with the installation and when you reach the Installation Options dialog click on Custom Partitioning . A window like bellow should open

image description

and the the NTFS partition should be listed. The NTFS partition you've created before in order to install Fedora. Be careful about what NTFS partition you will select. Check the space (GB) , make sure that is the correct one. Select it and click the add icon (+).

I would suggest here to not use an LVM , but a standard partition instead.

Then you should see a window like this

image description

Assign the mount point on root . It is a slash symbol. /

Device Type : Standard partition

Filesystem: Ext4

Tick the reformat box.

When you are ready click on Update Settings . From this point and on, you should be able to proceed with the rest of Installation.

Swap space:

If you want to create a swap space too, then leave some space (desired capacity) for the swap partition. If you have a memory of 4GB and over, swap isn't needed, but opinions varies. You have to repeat the same procedure for swap partition, but in Filesystem you must select swap.

edit flag offensive delete link more

Comments

Why does he have to download a 64 bit system? He hasn't mentioned his hardware specifications anywhere..

FranciscoD_ gravatar imageFranciscoD_ ( 2014-02-02 02:26:39 -0600 )edit

Correct, but he runs already Windows 8 and I assume he has a 64bit capable CPU. Just guessing. Also I think the 64bit image is more compatible with UEFI systems.

NickTux gravatar imageNickTux ( 2014-02-02 02:31:37 -0600 )edit

It's safer to not assume when helping users, novice or not. I've had cases where I assumed information only to later find out that it messed things up :(

FranciscoD_ gravatar imageFranciscoD_ ( 2014-02-02 04:44:24 -0600 )edit

Yes, but this is a safe supposition. If he has a 32bit CPU (not capable for 64bit OS) then, the .iso (boot from USB) will not start at all. No damage can generated by this.

NickTux gravatar imageNickTux ( 2014-02-02 05:17:31 -0600 )edit

i have follow this instruction for my F20 with Win8.1, all setup done. but, when restart and select Win8, nothing happened. just black screen with blinking dash.

Any step required? install grub2 maybe?

doniafrizal gravatar imagedoniafrizal ( 2014-03-18 22:18:46 -0600 )edit
1

answered 2014-02-01 19:46:57 -0600

aeperezt gravatar image

The partition should be empty if you have it as F: on windows it means that is already created and parted, you need it to be empty space with no partition asign.

edit flag offensive delete link more

Comments

This didn't work when I installed Fedora 20 as dual/triple boot. The empty space haven't been recognized at all. I don't know why, but I know what you are saying is correct. So I proceeded with the manual partitioning, after I had re-formated the unallocated space with a filesystem.

NickTux gravatar imageNickTux ( 2014-02-02 02:41:44 -0600 )edit

If you can reproduce this, please file a bug. I triple boot Windows/ubuntu/Fedora and didn't run into this issue.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-02-02 04:43:49 -0600 )edit

@FranciscoD_ no I can't. I won't. I won't re-install Fedora, now that I have set it up as I want. But I have this in mind for future installations. I remember this very well, because it needed to install gparted (on live image) and re-format the unallocated space in order to be recognized(by the installer). It wasn't under the list in manual partitioning, neither the automatic(partitioning) installer let me to proceed.

NickTux gravatar imageNickTux ( 2014-02-02 05:25:16 -0600 )edit
0

answered 2016-06-13 01:43:07 -0600

bblair gravatar image

The fact is many people want a dual boot to use Windows for gaming, And Linux for everything else! Why some idiot would claim that is outdated? Who knows! Probably just a idiot. Anyway: Fedora should read the partitions while running live install! This is obviously a bug! People should not have to use windows to install Fedora on a partition! This was a deal breaker for me! I am not deleting my drive data or transferring it, when I can just simply choose to install a linux OS than can properly read partitions! If and when the Fedora devs decide to correct this, I may try it then.

edit flag offensive delete link more
0

answered 2014-06-30 13:12:49 -0600

Today I installed fedora 20, During installation I didn't find any option where to install grub ? Is it me who couldn't find this option anywhere during installation process or is it not really there to chose that option anymore and fedora installer assumes that users want to force grub on the disk instead of it's separate boot partition ?

edit flag offensive delete link more

Comments

1

This is a question, not an answer - but: - You can't install grub to partitions, there isn't room for it there. On BIOS systems, it must be installed to the MBR. - On UEFI systems, you don't install GRUB to the MBR, it gets installed to the EFI system partition, and referenced in the system firmware. There's no choice to be made at all.

randomuser gravatar imagerandomuser ( 2014-06-30 13:22:12 -0600 )edit
0

answered 2014-09-01 11:03:19 -0600

JohnC gravatar image

MY DRIVE IS FAILING!!!! I dual booted Fedora 20 with a Windows 8 Asus intel pentium 2020m@2.40GHz , 4GB RAM 500GB (Hitachi HT554505). Ok well I used the LVN setting when setting up partitions. I messed up once and it said sda7 was overlapping and it quit insallation. So I went back in and fixed it. Everything went good and installation completed or so I thought. Now it said the Hitachi drive is about fail ( I forget exact wording). Is this fixable I can change things around, but would like some advice to help me along. Thank you

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-02-01 19:20:46 -0600

Seen: 25,522 times

Last updated: Jun 13 '16