Ask Your Question
3

Suspending laptop upon lid close in Fedora 20

asked 2014-01-31 21:24:40 -0500

audifanatic518 gravatar image

updated 2014-09-30 15:03:03 -0500

mether gravatar image

Hello,

I've recently upgraded to Fedora 20 (clean install) and I've noticed that my laptop no longer suspends when I close the lid while I'm in Fedora. I should note that it works fine in Windows 7, so it's not a hardware issue. With that said, I also followed both suggestions from an earlier question to no avail. I'm using a Lenovo Thinkpad T510.

edit retag flag offensive close merge delete

Comments

Does the suspend works at all ? try it from terminal sudo pm-suspend

NickTux gravatar imageNickTux ( 2014-01-31 22:18:28 -0500 )edit

Yes, that works fine

audifanatic518 gravatar imageaudifanatic518 ( 2014-01-31 23:38:48 -0500 )edit

Sorry that I'm asking, but are you sure that doesn't suspend ? My laptop (when I close the lid) has a short delay/lag to go in to sleep, compared with other options (i.e. suspend from menu or command line), but it works. Also, what graphics card you have ? Have you installed any additional driver ?

NickTux gravatar imageNickTux ( 2014-01-31 23:48:37 -0500 )edit

Yea, I'm sure. Tossed it in my backpack earlier with a full battery, 4 hours later it was dead when I went to use it. Also, the cresent moon LED on the top never turns on like it should when suspending. I've got an NVIDIA NVS 3100M and no, I haven't installed any additional drivers.

audifanatic518 gravatar imageaudifanatic518 ( 2014-02-01 00:09:16 -0500 )edit

and you're using the kmod-nvidia drivers? akmods? nvidia binaries? nouveau? I'm assuming it has the switchable graphics (Optimus)?

ILMostro gravatar imageILMostro ( 2014-02-01 02:55:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-02 07:52:56 -0500

updated 2014-02-04 06:12:22 -0500

This is taken from the thinkwiki.org website, which has some information on installing Linux on the T510, as well as some workarounds:

System can only resume from suspend once - acpi related kernel crash occurs on resume (but system continues to operate), next resume shows BIOS screen and hangs - https://bugzilla.kernel.org/show_bug.cgi?id=15407 This can be resolved by updating the BIOS to a revision later than 1.18-1.10 . http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-74267

Suspend to RAM and Hibernate( suspend to disk ) works very well under Fedora 13 BETA (kernel 2.6.33), using both the proprietary Nvidia driver and the open source Nouveau driver.

If using the proprietary Nvidia driver (NVIDIA Driver Version 260.19.06) one has to set "Discrete" in BIOS. Linux seems to have some problems with Switchable Graphics (Optimus).

As noted in the kernel bug-report, update your BIOS if it's not the latest; take a look at that bug-report for more information and tips, such as: try to boot with the following kernel parameters acpi_sleep=sci_force_enable to see if it helps.

Also, you should search around some more on the web about nvidia Optimus (Switchable Graphics) and Linux. Take a look at this nvidia forum thread; depending on your graphics card, you might want to try installing the kmod-nvidia-304xx package--there are some bugs that nvidia has to resolve with the newest ones.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-31 21:24:40 -0500

Seen: 1,842 times

Last updated: Feb 04 '14