Ask Your Question
1

Failed to set new efi boot target

asked 2014-01-23 12:06:42 -0500

ifuze gravatar image

updated 2014-01-24 18:10:13 -0500

mether gravatar image

So I wanted to use Linux on my school pc and downloaded Fedora 20. Only that when I try to install it, it give the error "Failed to set new efi boot target". So what can I do to fix this? Bare in mind, I'm completely new to Linux :/

edit retag flag offensive close merge delete

Comments

I don't have a specific answer here, but a note: that's known to be an unfortunately general error message. What it basically means is we failed to edit the EFI boot manager configuration, but it doesn't provide any details. What we need to debug the problem accurately is the program.log file from the installer, which can be found in /tmp/ while the install is running. Unfortunately it's slightly tricky to do this, for a newbie - I have to go out right now, but I can try and post instructions later.

AdamW gravatar imageAdamW ( 2014-01-24 15:10:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-23 19:31:29 -0500

FranciscoD_ gravatar image

I found a bug filed here:

https://bugzilla.redhat.com/show_bug.cgi?id=1006304

Is the system you're trying to install to one with multiple hard disks? Please edit your question and provide more information on the hardware configuration of your system.

edit flag offensive delete link more

Comments

It only has one hard drive. The computer itself is Lenovo X121e. What more information do I need to provide?

ifuze gravatar imageifuze ( 2014-01-24 00:22:44 -0500 )edit
1

There's another related bug where the reporter seems to use a Lenovo too: https://bugzilla.redhat.com/show_bug.cgi?id=1047993

Unfortunately, it looks like an unsolved bug. A workaround could be to use it in legacy mode, but I'm not entirely sure if it's recommended.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-24 00:58:40 -0500 )edit
1

Alright, but I have installed it now by switching to legacy mode and it works great.

ifuze gravatar imageifuze ( 2014-01-24 14:38:16 -0500 )edit
0

answered 2014-01-24 01:48:20 -0500

Gileade Oseiass gravatar image

I had a similar problem I disabled security boot, and results. Try disabling the security boot (UEFI)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-01-23 12:06:42 -0500

Seen: 3,640 times

Last updated: Jan 24 '14