Ask Your Question
0

My Firewall configuration is greyed out (can't connect)

asked 2014-01-20 22:09:05 -0500

JC Lee gravatar image

I'm running Fedora 18. I guess I'm running Gnome (I don't know what that is beyond a desktop thing...) I can connect to the internet. I'm ultimately trying to do a Remote Desktop. I'm logged in as root user.

I tried two ways to get to the Firewall Configuration

  1. I go through Preferences>Firewall Greyed Out
  2. I type

    system-config-firewall

    command not found

This wiki site was last updated 2010.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-01-21 01:16:40 -0500

Ahmad Samir gravatar image

updated 2014-01-21 23:57:54 -0500

Reading https://fedoraproject.org/wiki/Features/firewalld-default it looks like Firewalld ( https://fedoraproject.org/wiki/FirewallD ) became the default firewall since F18. The command to launch the firewalld configuration tool is firewall-config.

To see if firewalld is enabled:

systemctl status firewalld.service

when you launch firewall-config ideally a polkit authentication dialogue pops up asking for the root password.

edit flag offensive delete link more
0

answered 2014-01-21 22:51:53 -0500

JC Lee gravatar image

updated 2014-01-21 22:53:28 -0500

I appreciate it. It said it was disabled so I then...

systemctl enable firewalld.service

systemctl start  firewalld.service

It's full of color now! You wouldn't happen to know how to remote desktop into Fedora from Windows? (or where to look? there seems to little info out there.)

edit flag offensive delete link more

Comments

Just to be on the safe side, these two services should be disabled if firewalld is used, check the output of `systemctl status ip6tables.service iptables.service`.

Ahmad Samir gravatar imageAhmad Samir ( 2014-01-22 01:01:46 -0500 )edit

Question Tools

Stats

Asked: 2014-01-20 22:09:05 -0500

Seen: 482 times

Last updated: Jan 22 '14