Ask Your Question
1

Graphical desktop does not start on fedora 20

asked 2014-01-12 02:40:47 -0500

rlmalone gravatar image

updated 2014-01-21 00:18:21 -0500

davidva gravatar image

Hi my problem has not been fixed. It may be a matter of the screen resolution for the initial GNOME display. Don't know how to change it from the boot: prompt before using GNOME desktop for the first time after installation. Please give (what should be in the Fedora 20 installation docs) the complete steps from desktop selection on the install screen to the point that I login with a user on the first login after installation. KDE works fine! Why shouldn't GNOME desktop out of the bos?

Bug 955779 - graphical GNOME desktop does not start after ISO install

edit retag flag offensive close merge delete

Comments

Is there a question here?

FranciscoD_ gravatar imageFranciscoD_ ( 2014-01-12 02:41:39 -0500 )edit

Try install lightdm, su -c 'yum -y install lightdm lighdtdm-gkt systemctl' next su -c 'systemctl disable gdm' next su -c 'systemctl enable lightdm'

davidva gravatar imagedavidva ( 2014-01-21 01:01:49 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-19 23:33:11 -0500

abadrinath gravatar image

Hello guys!

I experienced the same problem from my first install, and finally found a workaround to cure it. I tried @Kunal's idea, but it is definitely not because of SELinux. To fix it, use kdm or any other display managers:

First, yum install kdm

Next, systemctl disable gdm; systemctl enable kdm.

Last, reboot and choose GNOME from the Select Desktop section of the login.

While not that relevent, I also find that kdm loads way quicker than gdm, which takes 10 sec while kdm takes 0.5 seconds. This is not a complete answer, but rather a workaround.

edit flag offensive delete link more
2

answered 2014-01-12 02:50:00 -0500

robatino gravatar image

This bug is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=946964 , which I was the reporter of. It does not appear to affect F20 at all. (I experienced the bug in F19 on one bare metal machine and 2 VMs. None are affected in F20.) So the bug was probably fixed in GNOME 3.10. Even if you are seeing this bug, you could work around it by using a display manager other than gdm (for example, kdm or lightdm).

edit flag offensive delete link more
0

answered 2014-01-20 19:48:16 -0500

rlmalone gravatar image

My problem has not been fixed.

It may be a matter of the screen resolution for the initial GNOME display. Don't know how to change it from the boot: prompt before using GNOME desktop for the first time after installation. Please give (what should be in the Fedora 20 installation docs) the complete steps from desktop selection on the install screen to the point that I login with a user on the first login after installation. KDE works fine! Why shouldn't GNOME desktop out of the bos?

edit flag offensive delete link more
-2

answered 2014-07-19 08:20:46 -0500

Kunal gravatar image

updated 2014-08-13 13:02:13 -0500

Probably SELinux is preventing from startup. Mine too was not starting . And here's what i did to solve my problem :

1: Selected  2 option (rescue mode) and press e ;
2: Added 3 in front of .....rhb quiet (Like this : **rhb quiet "3**") and press ctrl+ x
3:Then i logged in as root in virtual terminal  and typed **startx**  and pressed enter
4: Then i was logged in graphically
5: i disabled by SELinux . Like this
       Open terminal.  type this : vi /etc/selinux/conf and press enter;
                              Edit the line SELINUX=enforcing to **SELINUX=disabled**
6 : Reboot normally and voila problem solved
edit flag offensive delete link more

Comments

Not a secure solution at all.

abadrinath gravatar imageabadrinath ( 2014-07-26 01:14:58 -0500 )edit

Question Tools

Stats

Asked: 2014-01-12 02:40:47 -0500

Seen: 18,166 times

Last updated: Aug 13 '14