Ask Your Question
1

Messed up Static IP assignment. Need to go back to DHCP.

asked 2014-01-10 15:31:45 -0500

JC Lee gravatar image

updated 2014-01-10 16:32:07 -0500

I'm running Fedora 16.

Without changing anything, I was able to connect to the internet. This was done using a DHCP server. Next, I wanted to apply a static IP address. I did so through the GUI Network settings that's found next to the speaker icon, time, etc. I went to IPv4 and switched to manual. I then added four addresses:

  • IP Address 192.168.0.15
  • Subnet Mask 255.255.255.0
  • Default Gateway 192.168.0.1
  • DNS 68.105.28.12

I rebooted and ran ifconfig; it shows an IP address of what I assigned (192.168.0.15). But, I cannot access the internet, or the same GUI Network settings window that I used to change from "automatic" to "manual."

What I didn't do was directly alter any of the network-scripts such as my router: "ifcfg-E77C98," since I found inconsistent tutorials on how to edit the scripts (that's why I used the GUI Network Settings window).

I wouldn't mind using a static IP or DHCP-assigned address.

ADDITIONAL COMMENTS I do not have a directory called Newtork; it's a file with the following:

  • default 0.0.0.0
  • loopback 127.0.0.0
  • link-local 169.254.0.0

I made up 192.168.0.15 since my (separate) laptop is 192.168.0.14. The DNS I looked up from the command prompt on my laptop.

edit retag flag offensive close merge delete

Comments

Does your router give you this IP-Address via DHCP that you manually set or could it be that the router gave that address automatically to anther device? Where did you get the IP for the DNS?

mithrial gravatar imagemithrial ( 2014-01-10 16:25:57 -0500 )edit

I made up 192.168.0.15 since my (separate) laptop is 192.168.0.14. The DNS I looked up from the command prompt on my laptop.

JC Lee gravatar imageJC Lee ( 2014-01-10 16:29:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-01-13 03:04:54 -0500

JC Lee gravatar image

I found the answer to my troubles...

As I followed this tutorial--which has typos and wrong wording--it was these commands that "shut-down" my GUI Network window:

systemctl stop NetworkManager.service
systemctl disable NetworkManager.service

What happened was the wrong wording of the following two commands to enable and restart the Network Manager: replace "network" with "NetworkService."

edit flag offensive delete link more
0

answered 2014-01-11 02:13:41 -0500

radioact1ve gravatar image

Can you change the settings by running:

/usr/bin/nm-connection-editor

from the command line? I believe that's the GUI Network settings window you're looking for.

Another option is to set the static ip via your router. You tell it the MAC address and the ip address you'd like to assign.

edit flag offensive delete link more

Comments

That command gave me a bunch of gibberish text. Fortunately, I backtracked a tutorial that I went through and found my mistake. I posted it as the answer.

JC Lee gravatar imageJC Lee ( 2014-01-13 03:06:22 -0500 )edit

Odd. It should have launched NetworkManager editor so that you could change it back to automatic. All good though. Glad you were able to fix the problem.

radioact1ve gravatar imageradioact1ve ( 2014-01-13 15:22:41 -0500 )edit

Question Tools

Stats

Asked: 2014-01-10 15:31:45 -0500

Seen: 846 times

Last updated: Jan 13 '14