Ask Your Question
2

How to make chrome work with flash-plugin ?

asked 2014-01-04 06:18:01 -0500

Shyama gravatar image

updated 2014-01-05 06:38:10 -0500

FranciscoD_ gravatar image

I installed flash-plugin and chrome in my dekstop. Flash works in firefox but not in chrome. I get "Shockwave Flash has crashed" error. I tried reinstalling from different sources but no use. Even tried this

ln -s /usr/lib/mozilla/plugins/libflashplayer.so /opt/google/chrome/plugins/libflashplayer.so.

Please share me if any solution exists.

edit retag flag offensive close merge delete

Comments

1

Do you mean Chrome or Chromium?

Chrome comes with Flash pre-installed, nothing is needed, it works out of the box on Linux.

If it is crashing, try to update Chrome version. Paste here the page you are experiencing the crash on so we can check on our Chrome versions as well.

lzap gravatar imagelzap ( 2014-01-04 07:31:07 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-01-04 08:26:06 -0500

Shyama gravatar image

Yes, Chrome comes with flash preinstalled. I tried to update but it didn't work. At last i found the solution.

I browsed thru chrome://plugins and there were two plugins for Flash. One is chrome's default and the other one I installed. I disabled the one in "/opt/google/chrome/PepperFlash/libpepflashplayer.so" and the problem disappeared.

Adobe Flash Player (2 files) - Version: 11.2 r202

Shockwave Flash 11.2 r202 Name: Shockwave Flash Description: Shockwave Flash 11.9 r900 Version: 11.9.900.170 Location: /opt/google/chrome/PepperFlash/libpepflashplayer.so Type: PPAPI (out-of-process)

Name: Shockwave Flash Version: 11.2 r202 Location: /usr/lib/flash-plugin/libflashplayer.so Type: NPAPI

edit flag offensive delete link more
1

answered 2014-01-04 21:42:30 -0500

antjavmd gravatar image

Hello.

My suggestion is not to install the Flash plugin if you intend to use Google Chrome as your primary browser. Google Chrome actually comes with Flash running atop its custom platform. Just installing Chrome should allow you to play Flash just fine.

edit flag offensive delete link more
0

answered 2014-01-15 20:29:03 -0500

Nirmal gravatar image

Setting SELinux policy to 'Permissive' solves the issue of "Shockwave Flash has crashed" error.

$ getenforce Enforcing $ sudo setenforce 0 $ getenforce Permissive $

Some websites (e.g. http://xfinitytv.comcast.net/live/network/cnn) need newer version of Flash player, ver 11.8 & above. Latest Chrome comes with Flash Version 12.0.0.41.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-01-04 06:18:01 -0500

Seen: 15,102 times

Last updated: Jan 15 '14