Ask Your Question
1

Fedora 20 crashes Eclipse with fault in libgtk-x11-2.0.so

asked 2013-12-27 09:22:14 -0500

ravencsi gravatar image

updated 2013-12-29 00:20:04 -0500

FranciscoD_ gravatar image

After fedup from 18 to 20, Eeclipse will not start. The JVM crashes and reports a problme outside the JVM in Problematic frame: C [libgtk-x11-2.0.so.0+0x28447e] gtk_widget_set_tooltip_text+0x1e.

No problems in 18. How can this be fixed?

edit retag flag offensive close merge delete

Comments

Have you installed the Google Talk plugin? Because there is a known issue between Eclipse and this plugin.

remjg gravatar imageremjg ( 2013-12-27 09:31:29 -0500 )edit

No, Google talk plugin was not installed. I searched for it just to be sure,and it is not on the machine. The only thing that changes was the upgrade from 18 to 20!

Could this be a video driver issue? The install is on a Lenovo T520 and I had issues with thvideo drivers intially - possible that upgrade wiped out those fixes.

BTW, the Eclipse version is 3.7.

ravencsi gravatar imageravencsi ( 2013-12-27 11:09:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-29 00:17:40 -0500

FranciscoD_ gravatar image

Try the steps outlined here and clean up your system:

http://fedorasolved.org/Members/fenris02/post_upgrade_cleanup

It could be some remnant files from the F18 installation. Also try running eclipse from the terminal and see what errors it gives. Please edit and update your question with whatever information you can provide.

edit flag offensive delete link more
0

answered 2013-12-27 09:37:02 -0500

mtk gravatar image

there have been threads in other places that say (strangely enough) that eclipse crashes are caused by the google-talk plugin. empirically, it is true since removing the plug in stopped my own eclipse crashes.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-27 09:22:14 -0500

Seen: 1,063 times

Last updated: Dec 29 '13