Ask Your Question
2

bumblebee does not work on fedora 20

asked 2013-12-23 14:58:45 -0500

Pooria gravatar image

updated 2013-12-24 20:41:04 -0500

FranciscoD_ gravatar image

I have installed bumblebee on fedora 20, but it does not work.

Here is the SELinux Alert detail:

SELinux is preventing /usr/sbin/bumblebeed from read access on the file bumblebeed.pid.

Current solution should be to allow this access by executing:

grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp

But it does not work because there is no mypol.pp. What should I do?

EDIT:

Actually, the complete error report is:

SELinux is preventing /usr/sbin/bumblebeed from read access on the file bumblebeed.pid.

Plugin catchall (100. confidence) suggests *******

If you believe that bumblebeed should be allowed read access on the bumblebeed.pid file by default. Then you should report this as a bug. You can generate a local policy module to allow this access. Do allow this access for now by executing:

grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp
Additional Information: Source Context system_u:system_r:bumblebee_t:s0 Target Context unconfined_u:object_r:var_run_t:s0 Target Objects bumblebeed.pid [ file ] Source bumblebeed Source Path /usr/sbin/bumblebeed Port <unknown> Host localhost.localdomain Source RPM Packages bumblebee-3.2.1-4.fc20.x86_64 Target RPM Packages 
Policy RPM selinux-policy-3.12.1-106.fc20.noarch Selinux Enabled True Policy Type targeted Enforcing Mode Enforcing Host Name localhost.localdomain Platform Linux localhost.localdomain 3.11.10-301.fc20.x86_64 #1 SMP Thu Dec 5 14:01:17 UTC 2013 x86_64 x86_64 Alert Count 1 First Seen 2013-12-23 17:15:27 IRST Last Seen 2013-12-23 17:15:27 IRST Local ID 117a37cc-f950-4b9f-98d6-f93fd1c61f38

Raw Audit Messages type=AVC msg=audit(1387806327.302:754): avc: denied { read } for pid=5559 comm="bumblebeed" name="bumblebeed.pid" dev="tmpfs" ino=39372 scontext=system_u:system_r:bumblebee_t:s0 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file

type=SYSCALL msg=audit(1387806327.302:754): arch=x86_64 syscall=open success=yes exit=ESRCH a0=9df300 a1=0 a2=ffffffff a3=7fff3a6c9d90 items=0 ppid=1 pid=5559 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=bumblebeed exe=/usr/sbin/bumblebeed subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: bumblebeed,bumblebee_t,var_run_t,file,read

and when I enter: grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol as root, the answer is: compilation failed: sh: /usr/bin/checkmodule: No such file or directory

edit retag flag offensive close merge delete

Comments

sudo yum install /usr/bin/checkmodule and then re-run the grep .. command. That will generate mypol.pp etc.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-12-24 20:42:26 -0500 )edit

Please do not provide information as answers in the future. Please update your question with additional info. I've done it for you this time. :)

FranciscoD_ gravatar imageFranciscoD_ ( 2013-12-24 20:43:09 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-12-24 06:42:55 -0500

deusdara gravatar image

Hi

Are you really using an nVidia Optimus card?

Only laptops have these kind of nVidia Optimus card, so this project won't apply to desktops (for now).

https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting

edit flag offensive delete link more
0

answered 2014-01-02 11:59:36 -0500

remjg gravatar image

updated 2014-01-02 12:01:06 -0500

I had the the same issue, I couldn't allow the access using the commands suggested:

grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol
compilation failed:
sh: /usr/bin/checkmodule: No such file or directory

Indeed, you first need to install the package checkpolicy:

yum install checkpolicy

Then you can run the following commands as root which should solve your issue (the last command deletes the mypol.pp once the policy module is installed):

grep bumblebeed /var/log/audit/audit.log | audit2allow -M mypol
semodule -i mypol.pp
rm -f mypol.pp
edit flag offensive delete link more
0

answered 2013-12-24 06:44:51 -0500

FranciscoD_ gravatar image

Follow the instructions properly. They work. A mypol.pp file should've been created. If it isn't some errors should be reported. Please update your question with these.

Please note that the semodule command needs to be run as root, and you need to provide the complete path to mypol.pp if it isn't in the current directory.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-23 14:58:45 -0500

Seen: 1,393 times

Last updated: Jan 02 '14