Ask Your Question
1

How can I set PCManFM file manager as default [closed]

asked 2013-12-22 06:29:53 -0500

iskenderoguz gravatar image

updated 2013-12-22 08:14:13 -0500

remjg gravatar image

How can I set PCManFM file manager as default file manager on Fedora 20 ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Akshay
close date 2013-12-22 14:34:18.061914

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-12-22 07:55:12 -0500

remjg gravatar image

updated 2013-12-22 07:58:07 -0500

You can use the xdg-mime command line tool for configuring the default applications of a user. The xdg-open page of the ArchWiki has been useful to me to find details about it.

To set PCManFM as the default file manager, type the following command in a terminal:

xdg-mime default pcmanfm.desktop inode/directory

To set back Nautilus as the default file manager, use this command:

xdg-mime default nautilus.desktop inode/directory
edit flag offensive delete link more

Comments

Thank you I changed my default file manager. But when I double-click an icon on desktop nautilus opened. How can I solve this?

iskenderoguz gravatar imageiskenderoguz ( 2013-12-22 09:48:19 -0500 )edit

If you want PCManFM to handle the desktop, you can use the command pcmanfm --desktop according to this page. The problem is that this command must be run each time you log in.

remjg gravatar imageremjg ( 2013-12-22 10:09:05 -0500 )edit

As a ugly hack, you might want to edit the /etc/xdg/autostart/nautilus-autostart.desktop file and change the line Exec=nautilus -n to Exec=pcmanfm --desktop. But It doesn't seem to work very well, I don't see any icons for example.

I can't tell you more since I don't handle the desktop with a file manager.

remjg gravatar imageremjg ( 2013-12-22 10:41:20 -0500 )edit

Question Tools

Stats

Asked: 2013-12-22 06:29:53 -0500

Seen: 2,487 times

Last updated: Dec 22 '13