Ask Your Question
0

Installing software (VirtualBox, Steam, MATE) failed in Fedora 20

asked 2013-12-17 12:48:22 -0500

VoidByte gravatar image

updated 2014-04-14 15:22:01 -0500

mether gravatar image

Hello, ex Debian´ er here,

i just come to the new fancy F20, and im really happy about this change. But pieces of Software are not installable, why? (i would give you a inxi -F output but it seems like fedora dont have inxi ^^)

Here is what i does:

[Void.net@VoidCore ~]$ sudo yum install steam

and after a looooot of things, it stops somewhere around here:

--> Abhängigkeit libattr.so.1 wird für Paket libcap-2.22-7.fc20.i686 verarbeitet
---> Paket libgcrypt.i686 0:1.5.3-2.fc20 markiert, um installiert zu werden
---> Paket libgpg-error.i686 0:1.12-1.fc20 markiert, um installiert zu werden
---> Paket pam.i686 0:1.1.8-1.fc20 markiert, um installiert zu werden
--> Abhängigkeit libdb-5.3.so wird für Paket pam-1.1.8-1.fc20.i686 verarbeitet
--> Abhängigkeit libcrack.so.2 wird für Paket pam-1.1.8-1.fc20.i686 verarbeitet
---> Paket xz-libs.i686 0:5.1.2-6alpha.fc20 markiert, um installiert zu werden
--> Transaktionsprüfung wird ausgeführt
---> Paket cracklib.i686 0:2.9.0-5.fc20 markiert, um installiert zu werden
---> Paket libattr.i686 0:2.4.47-3.fc20 markiert, um installiert zu werden
---> Paket libdb.i686 0:5.3.28-1.fc20 markiert, um installiert zu werden
--> Abhängigkeitsauflösung beendet
Fehler:  Multilib version problems found. This often means that the root
        cause is something else and multilib version checking is just
        pointing out that there is a problem. Eg.:

          1. You have an upgrade for sqlite which is missing some
             dependency that another package requires. Yum is trying to
             solve this by installing an older version of sqlite of the
             different architecture. If you exclude the bad architecture
             yum will tell you what the root cause is (which package
             requires what). You can try redoing the upgrade with
             --exclude sqlite.otherarch ... this should give you an error
             message showing the root cause of the problem.

          2. You have multiple architectures of sqlite installed, but
             yum can only see an upgrade for one of those architectures.
             If you dont want/need both architectures anymore then you
             can remove the one with the missing update and everything
             will work.

          3. You have duplicate versions of sqlite installed already.
             You can use "yum check" to get yum show these errors.

        ...you can also use --setopt=protected_multilib=false to remove
        this checking, however this is almost never the correct thing to
        do as something else is very likely to go wrong (often causing
        much more problems).

        Geschützte Multilib-Versionen: sqlite-3.8.1-2.fc20.i686 != sqlite-3.8.2-1.fc20.x86_64
Fehler: Geschützte Multilib-Versionen: libpciaccess-0.13.1-4.fc20.i686 != libpciaccess-0.13.2-1.fc20.x86_64

Then, VirtualBox:

[Void.net@VoidCore ~]$ sudo yum install VirtualBox

result in a quick:

Installieren  2 Pakete (+3 Abhängige Pakete)

Gesamtgröße: 60 M
Installationsgröße: 220 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  package kernel-3.12.5-301.fc20.x86_64 (which is newer than kernel-3.11.10-301.fc20.x86_64) is already installed ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2013-12-18 08:11:41 -0500

toxn gravatar image

updated 2013-12-18 08:18:13 -0500

First of all, you should verify that there isn't a package conflict due to your recent update, with

sudo yum clean all
sudo rpm --rebuilddb
sudo package-cleanup --problems

Your problems can come from duplicate packages. This can be solved (most of the time) with

sudo package-cleanup --cleandupes

For your first problem (steam install), it seems you have two different sqlite versions (3.8.1-2 and 3.8.2-1) on two different architectures (x86_64 and i686) installed. I would start with trying to deal with that either by synchronizing both version :

sudo yum --showduplicates list sqlite

and then upgrade or downgrade as needed. Or simply remove the one you may not need:

sudo yum remove sqlite.i686

You can also follow yum's multilib advice:

sudo yum --exclude sqlite.i686 install steam

or

sudo yum --setopt=protected_multilib=false install steam

The latter may trash your system a bit more.

edit flag offensive delete link more

Comments

I have steam and virtualbox from rpmfusion installed on F20 without any kind of problems : steam-1.0.0.45-1.fc20.i686 kmod-VirtualBox-4.3.6-2.fc20.x86_64 VirtualBox-4.3.6-4.fc20.x86_64 kmod-VirtualBox-3.12.6-300.fc20.x86_64-4.3.6-2.fc20.x86_64

sergiomb gravatar imagesergiomb ( 2014-01-03 17:45:32 -0500 )edit
0

answered 2013-12-18 17:24:29 -0500

quantenselbstmord gravatar image

Hello void if you wanna install mate enviroment you run :

yum -y groupinstall mate-desktop

now for install virtualbox:

su -c 'yum -y install binutils gcc make patch libgomp glibc-headers glibc-devel kernel-headers kernel-devel dkms'

yum -y localinstall http://download.virtualbox.org/virtualbox/4.3.4/VirtualBox-4.3-4.3.4_91027_fedora18-1.x86_64.rpm

sudo /etc/init.d/vboxdrv setup

usermod -a -G vboxusers username

check that the kernel is update before install virtualbox , else sudo /etc/init.d/vboxdrv setup give error

good luck !

edit flag offensive delete link more
0

answered 2013-12-18 08:58:07 -0500

I am also unable to install some software in Fedora 20.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-17 12:48:22 -0500

Seen: 3,736 times

Last updated: Dec 18 '13