ioapic 2 has no mapping

asked 2013-12-12 15:01:34 -0500

appleiscrap gravatar image

updated 2014-09-30 21:39:00 -0500

mether gravatar image

Hi, booting up fedora 20 live from usb stick on a retina apple crap book pro first displays a message "Secure boot not enabled" followed by

[Firmware Bug]: ioapic 2 has no mapping iommu, interrupt remapping will be disabled. 
pci 0000:00:01.0: ASPM: Could not configure common clock
i915 0000:00:02.0: Invalid ROM contents irq 17: nobody cared (try booting with the "irqpoll" option)

How can the 'irqpoll' option be set? Any other ideas how to get fedora 20 to boot on a retina crap book pro? Thanks

edit retag flag offensive close merge delete

Comments

Simply add irqpoll to (read carefully): GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora_test-pc/swap rd.lvm.lv=fedora_test-pc/root rhgb acpi_osi=Linux irqpoll quiet". Located in /etc/default/grub. Dont forget to regenerate grub.cfg. Execute the command as ROOT (su): grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg.

And about interrupt remaping being disabled AFAIK is a problem that Apple don't seems to care about, not really sure about it! I'm still looking a solution for this!

EDIT: disable interrupt remapping adding intremap=off to the kernel boot param will solve the issue.

GabeNa gravatar imageGabeNa ( 2015-06-11 00:22:56 -0500 )edit