Ask Your Question
1

How to Install Cisco Packet Tracer 6.0.1 on Fedora 19 64-bit?

asked 2013-12-10 10:15:22 -0500

elemer82 gravatar image

updated 2014-05-11 13:43:43 -0500

mether gravatar image

Hello,

I just managed to install Cisco Packet Tracer 6.0.1 onto Fedora 19 64-bit. I want to describe my commands which made it halfway possible:

cd /to/the/location/of/the/Packet/Tracer/file

tar -xvzf PT601LinuxNoTutorial

(I changed the file name into PT601LinuxNoTutorial for ease of use; It doesn't have an extension - that's how I got from Cisco website, but it's a .tar.gz apparently)

cd ./PacketTracer601

bash ./install

(Here you have to read the EULA - and hit Enter until the end of the list)

Do you accept the terms of the EULA? (Y)es/(N)o

y

Enter location to install Cisco Packet Tracer or press enter for default [/opt/pt]:

(Change if needed, or just hit Enter)

Should we create a symbolic link "packettracer" in /usr/local/bin for easy Cisco Packet Tracer startup? [Yn]

y

Then it says Packet Tracer installed succesfully.

Here comes the tricky part: type in terminal

packettracer

it shows "Starting Packet Tracer 6.0" but nothing starts ever. I tried sevaral things and finally got it working with this command:

sudo yum install libacpi.i686 libacpi.x86_64

Then as suggested by marcindulak you have to make a packettracer.desktop file in ~/.local/share/applications For this copy and paste the following in terminal:

cat > ~/.local/share/applications/packettracer.desktop << "EOF"
[Desktop Entry]

Encoding=UTF-8
Type=Application

Exec=/opt/pt/packettracer
Icon=/opt/pt/art/app.png

Name=Cisco Packet Tracer
Categories=Application;Network;

MimeType=application/octet-stream;
X-Desktop-File-Install-Version=0.21
EOF

The above presumes that you have installed Packet Tracer in the default location (/opt/pt) if not than correct as required. I just took the packettracer.desktop file from ubuntu (I dual boot) and that is the content in packettracer.desktop. This works for now.

sudo gedit /usr/share/applications/mimeinfo.cache

and/or

sudo gedit ~/.local/share/applications/mimeinfo.cache

and insert the following line:

application/octet-stream=packettracer.desktop;

At this point I can start Packet Tracer from Terminal and from the Windows and IS associated with packet tracer.

Kind of solved. :)

edit retag flag offensive close merge delete

Comments

marcindulak gravatar imagemarcindulak ( 2013-12-10 11:00:10 -0500 )edit

That is useless. Anything else?

elemer82 gravatar imageelemer82 ( 2013-12-10 13:53:41 -0500 )edit

Please elaborate: do you need further guidance how to create a desktop file?

marcindulak gravatar imagemarcindulak ( 2013-12-11 02:19:44 -0500 )edit

I tried to make a .desktop file but maybe it is not as simple if you don't know what you are doing. In the location suggested by that post (~/.local/share/applications) there is only 2 files "mimeapps.list" "mimeinfo.cache" and the one I created "packettracer.desktop" . However /usr/share/applications is full of .desktop files.

elemer82 gravatar imageelemer82 ( 2013-12-11 03:06:32 -0500 )edit

Yes, ~/.local/share/applications is you personal directory. Place the desktop file there first. In order to check if it starts correctly do gtk-launch packettracer

marcindulak gravatar imagemarcindulak ( 2013-12-11 06:00:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-25 00:21:35 -0500

There is much simpler way....

Goto terminal >> yum install wine [nearly 183 Mb of download]

then Run wine..... Let it update [ May take time]

the Run File manager...... Run packet tracer.exe file.... Setup will run...

%%% Packet Tracer Runs Smoothly as on windows %%%%

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-12-10 10:15:22 -0500

Seen: 16,346 times

Last updated: Feb 25 '15