Ask Your Question
0

Network svc doesnt start in FC19 without NetworkManager: Solution

asked 2013-11-24 20:37:23 -0500

wsanders gravatar image

updated 2013-11-24 20:37:54 -0500

I tried to get the network service to start without Network Manager:

systemctl disable NetworkManager
added this line to /etc/sysconfig/network-scripts/ifcfg-enp2s0: NM_CONTROLLED=NO

It doesn't work, the network service is not started at boot. The network service then starts OK "by hand" after boot. It appears that maybe even though NetworkManager is disabled, and I see no daemon running after boot, it tries to run anyway during boot, since there are these entries in the syslog:

Nov 24 18:16:38 4core NetworkManager[434]: <info> Networking is enabled by state file
Nov 24 18:16:38 4core NetworkManager[434]: <warn> failed to allocate link cache: (-10) Operation not supported
Nov 24 18:16:38 4core NetworkManager[434]: <info> (p2p1): carrier is OFF
Nov 24 18:16:38 4core NetworkManager[434]: <info> (p2p1): new Ethernet device (driver: 'r8169' ifindex: 2)
Nov 24 18:16:38 4core NetworkManager[434]: <info> (p2p1): exported as /org/freedesktop/NetworkManager/Devices/0
Nov 24 18:16:38 4core NetworkManager[434]: <info> (p2p1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Nov 24 18:16:38 4core NetworkManager[434]: <info> (p2p1): bringing up device.
Nov 24 18:16:38 4core systemd[1]: Started Network Manager.
Nov 24 18:16:38 4core systemd[1]: Starting Network.
etc

No mention of it failing. Is there perhaps a dependency that prevents NetworkManager from being disabled?

The workaround is to let NetworkManager stay enabled. It doesn't seem to cause any difficulties.

Contents of /etc/sysconfig/network-scripts/ifcfg-enp2s0: DEVICE=p2p1 BOOTPROTO=none ONBOOT=yes ADDRESS=192.168.1.97 NETMASK=255.255.255.0 GATEWAY=192.168.1.254 IPADDR=192.168.1.97 TYPE=Ethernet USERCTL=no IPV6INIT=yes PEERDNS=yes DNS1=208.201.224.11 DNS2=208.201.224.33

Anyway, HTH if anyone is having a problem. Don't disable NetworkManager, it doesn't seem to cause any problems if left to run.

-w sanders wsanders.net

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-29 14:47:20 -0500

Ken Stailey gravatar image

Try adding one of these to /etc/sysconfig/network-scripts/ifcfg-enp2s0

Either:

LINKDELAY=60

Or if that doesn't work try:

check_link_down () { return 1; }

and let me know what happens.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-24 20:37:23 -0500

Seen: 863 times

Last updated: Nov 29 '13