Ask Your Question
1

Intel Ethernet not recognized after kernel update

asked 2013-11-23 22:23:32 -0500

mbramson gravatar image

updated 2013-11-24 16:30:58 -0500

I just installed Fedora 19. The Ethernet was working fine at first, but after installing updates for the first time following installation, which included an update in kernel version from 3.9 to 3.11, my wired connection no longer works. It is not listed in ifconfig. lspci gives:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I218-V (rev 04)

After much searching around, I don't know what the next thing to check is. Any suggestions?

Edit: Mysteriously, after rebooting again today, the Ethernet works. I don't know what happened. I can't close the question myself, but the issue is resolved.

edit retag flag offensive close merge delete

Comments

With lspci -v, could you add the driver in use if any. You may just need to install the extra drivers required - this worked for my SD card driver and graphics card, and should hopefully not muck up anything (check first): sudo yum install kmod-staging (for PAE kernels: sudo yum install kmod-staging-PAE.

wilf gravatar imagewilf ( 2013-11-24 15:07:56 -0500 )edit

Found this https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=15817

wilf gravatar imagewilf ( 2013-11-24 15:09:44 -0500 )edit

I would record which driver it is using when it works, and the internet settings - then add it as an answer. But, like you say, you need 20+ rep to mark your answer to your question.

wilf gravatar imagewilf ( 2013-11-26 13:44:23 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-26 14:17:59 -0500

mbramson gravatar image

As per my edit, it started working without any obvious manipulation on my end, but following wilf's suggestion, I will note that lspci -v indicates that it's using the e1000e driver.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-23 22:23:32 -0500

Seen: 2,188 times

Last updated: Nov 26 '13