Ask Your Question
0

Fedora 19 - crypttab and truecrypt volume

asked 2013-11-22 14:58:25 -0500

fulldisea gravatar image

Hello,

I wanted to set up automatic mounting of truecrypt volumes (one regular and one system) via crypttab and cryptsetup.

Here is the relevant portion of my crypttab:

truecrypt-volume1 /dev/sdb /etc/tc.passwd noauto,tcrypt-system

truecrypt-volume4 /dev/sda3 /etc/tc.passwd tcrypt,noauto

And here is the fstab entries:

/dev/mapper/truecrypt-volume1 /mnt/a auto noauto,x-systemd.automount 0 0

/dev/mapper/truecrypt-volume4 /mnt/b auto noauto,x-systemd.automount 0 0

Now, what this should do is mount the volumes using autofs,automount and cryptsetup when i try to access them. But automount part just stalls and I get this error message:

localhost systemd-cryptsetup[2010]: Encountered unknown /etc/crypttab option 'tcrypt-system', ignoring.

I get the same error for the other (non-system drive), i.e. the 'tcrypt' option is not recognized.

If I try to use cryptsetup to mount the volumes manually , it works like a charm. What could possibly be the problem? What am I missing?

Additionally, one thing confuses me. In the man page for crpytsetup it says that 'tcrypt-system' options needs to be given a device, not a partition , so /dev/sdb not /dev/sdb1 for example. How do I, then, specify where to mount the partitions in the fstab?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-24 05:07:57 -0500

fulldisea gravatar image

To answer my own question. systemd doesn't support tcrypt in fedora19. Upgrade to fedora20 solved the issue somewhat.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-22 14:58:25 -0500

Seen: 718 times

Last updated: Nov 24 '13