Ask Your Question
0

How can I disable auto gui from a live dvd? [SOLVED]

asked 2013-11-13 21:46:14 -0500

GordieGii gravatar image

updated 2014-09-28 11:51:47 -0500

mether gravatar image

How can I disable automatic launching of kdm on my installed hard disk from a live session.

Here's the scenario: Everything seems to be going well untill it's time for kdm to show up. Progress diamond fills up with a pretty f, The screen goes blank for a second (this is when kdm is supposed to show up) then the pretty f comes back. I can't open a terminal. Ctrl-Alt-Del reboots the machine. I try with the two previous kernals and even rescue entry in grub list, same stuff all around. I start a live session (with the same dvd I installed from months ago), mount root partition and check the boot log and everything seem fine up to the point KDE Login Manager starts. kdm log shows that it can't seem to find the nvidia screen. This I could most likely fix if get to console.

So how can I keep kdm from tying up my machine? Perhaps I don't need to modify something from a live session. Is there a key sequence I can hit during bootup that will keep kdm from launching?

Thanks in advance for any advice, Gordie

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-13 22:28:07 -0500

cjbayliss gravatar image

Answer No.1

Power on your computer, press esc when the diamond starts to fill and when all the text stops flying press ctrl+alt+F2 (or f3, f4, f5, f6).

Answer No.2

If the above does not work then you should try this:

Power on your computer, and when it gives you a list of boot options, press e. Now use the arrow keys and find the bit that says rgba quiet and change it to text 3 then press F10. Now it will boot into text mode.

edit flag offensive delete link more
0

answered 2013-11-15 21:33:56 -0500

GordieGii gravatar image

Thanks cjbayliss.

I ended up adding a '3' just before 'ro' in the command line before hitting F10. That gave me a login prompt. Not sure if the position matters. Just following instructions. This all happened before I even saw your post.

In case anybody is interested: It would seem that Apper or Yum or PackageKit twiddle with the grub config somehow so there is a 'blacklist=nouveau' in there even though it isn't in /etc/default/grub and it also makes the image names contain 'Schr?dingers Cat'. These both disappeared when I did my grub2-mkconfig so the nvidia drivers started conflicting with the nouveau drivers and BLAMMO! (I'm pretty sure that's the technical term for it...) I'm pretty sure the system was sitting there waiting for me to log in but had somehow lost track of the screen buffers so I couldn't see anything, even with a ctrl-alt-F2. So I added the 'blacklist=nouveau' to /etc/default/grub so that it was included when I mkconfig'd again. It would be interesting to know how the kernel update is modifying the grub config and see if there is anything else it is doing that I haven't noticed.

Gordie

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-13 21:46:14 -0500

Seen: 144 times

Last updated: Nov 15 '13