Ask Your Question

Mount fat32 but i want to execute files as a single user

asked 2013-11-13 12:43:49 -0500

Adam gravatar image


I have a little problem with my fat32 drive. I usually put files to this drive, but i can't change their permissions to execute them. Can you help me how to modify the fstab file to be able to read/write/execute files on this drive as a non-root user? Currently i have this in fstab:

UUID=7B81-3920 /shared vfat utf8,exec,uid=100,gid=100,user,rw,umask=000,fmask=111,dmask=000,shortname=winnt 0 2

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-11-14 04:55:08 -0500

marcindulak gravatar image

updated 2013-11-15 03:11:29 -0500

fmask=111 removes the execute permissions on the files - use 000. fmask works slightly different than umask - the latter applies the umask values to 666 on the files. I'm not aware of any good documentation about that so the best thing is to experiment with different fmask=XXX values:

su -c "umount /shared"
su -c "mount -o fmask=XXX UUID=7B81-3920 /shared"

Se also

edit flag offensive delete link more

Question Tools


Asked: 2013-11-13 12:43:49 -0500

Seen: 279 times

Last updated: Nov 15 '13