Ask Your Question
0

kdm stopped working after last kernal upgrade [SOLVED] [closed]

asked 2013-11-09 12:59:43 -0500

GordieGii gravatar image

updated 2014-09-28 11:51:58 -0500

mether gravatar image

After my last kernal upgrade (to Fedora 3.11.6-200.fc19.x86_64) kdm stopped showing up on screen. The screen just seems to stop in the middle of the boot process. I can alt-f2 and login then top shows that kdm is running.

If I boot with 3.11.4-201. fc19.x86_64 it works fine. My IT tech (son) suggested I use that until the next kernal upgrade.

Now 3.11.7-200.fc19.x86_64 does the same as 3.11.6-200.fc19.x86_64 did.

What is my next step?

Gordie

Zotac ION-ITX-A-U motherboard (that's an Intel ATOM N330 with an NVIDIA ION chipset) NVIDIA driver ver. 304.108

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Akshay
close date 2013-11-15 21:16:29.061272

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-11 14:02:55 -0500

edit flag offensive delete link more
0

answered 2013-11-11 23:23:09 -0500

GordieGii gravatar image

updated 2013-11-15 21:18:43 -0500

JUST got that update today. Didn't help.

The other thing I noticed is the resolution is really low, like 640x480, so I'm thinking the new kernal doesn't like my video chips. Maybe I have to tell it which mode to use instead of letting it guess.

2013-11-12 OK I have totally borked my system by trying to fiddle with the grub setting. I made one little change to the default file (to try and get a default dvorak layout. Once I ran grub2-mkconfig I can't boot any more, or to be more specific, by looking at the boot log it seems that everything is proceeding fine up to the point where KDM should come up and all I see is the pretty little f in the middle of the screen. I can't even bring up a terminal, and the rescue entry in the grub menu does the same thing as the other three.

Is there a way to disable automatic GUI from a live session. I can mount the root partition from there.

SOLUTION: Install the right nvidia driver version for the new kernel you want to run! Apparently there is a new build of the drivers for each kernel. Apparently it is not automatically updated when the kernel is updated.

Also for anybody else who didn't already know how to disable automatic gui startup: Select the kernel you want to run at the grub menu then press e and add a '3' to the Linux Command line. In my case right before 'ro', so 'something 3 ro' then hit F10 to boot and soon you will be the proud owner of a login prompt!

What I broke when I played with my grub config: It would seem that Apper or Yum or PackageKit twiddle with the grub config somehow so there is a 'blacklist=nouveau' in there even though it isn't in /etc/default/grub and it also makes the image names contain 'Schr?dingers Cat'. These both disappeared when I did my grub2-mkconfig so the nvidia drivers started conflicting with the nouveau drivers and BLAMMO! (I'm pretty sure that's the technical term for it...) I'm pretty sure the system was sitting there waiting for me to log in but had somehow lost track of the screen buffers so I couldn't see anything, even with a ctrl-alt-F2. So I added the 'blacklist=nouveau' to /etc/default/grub so that it will be included if I mkconfig again but it would be interesting to know how the kernel update is modifying the grub config and see if there is anything else it is doing that I haven't noticed.

Gordie

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-09 12:59:43 -0500

Seen: 181 times

Last updated: Nov 15 '13