Ask Your Question
1

help for ocrfeeder

asked 2013-11-09 12:09:07 -0500

oper gravatar image

updated 2014-09-28 08:42:09 -0500

mether gravatar image

I have install all the packages ( tesseract, python, leptonica, etc ). I have also installed ocrfeeder 0.7.11 but i can't open it ! I have the message : ocrfeeder crashed lib.py:23:<module>:ImportError:No module named Image !

Can you help me with this?

                                                           Thank You
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-19 07:11:51 -0500

Felix Schwarz gravatar image

updated 2013-11-19 07:14:44 -0500

The problem is that ocrfeeder is not compatible with Pillow. Pillow is a fork of the "PIL" library which can manipulate images (e.g. conversion and scaling).

# src/ocrfeeder/util/lib.py, line 23
import Image

I created a patch in the upstream issue tracker for that (completely untested!). You could try to apply the patch yourself, that should fix the problem you described.

Alternatively you can create a virtualenv and install one of the ancient PIL versions there (though I think fixing ocrfeeder is a much better time investment).

edit flag offensive delete link more

Comments

Felix, can you explain how to apply your patch?

padraic gravatar imagepadraic ( 2014-01-19 08:22:25 -0500 )edit
1

answered 2013-11-16 06:51:53 -0500

It seems that Pillow is missing. Please install it and try again.

$ sudo yum -y install python-pillow
edit flag offensive delete link more

Comments

usually the line above would be correct but please note that ocrfeeder is using "import Image" which doesn't work in Pillow (one of the few incompatible changes they made).

Felix Schwarz gravatar imageFelix Schwarz ( 2013-11-19 07:13:20 -0500 )edit

Question Tools

Stats

Asked: 2013-11-09 12:09:07 -0500

Seen: 611 times

Last updated: Nov 19 '13