Ask Your Question
1

grub2-mkconfig renders grub.cfg inoperable

asked 2013-11-08 12:17:06 -0500

bwolff gravatar image

updated 2013-11-09 16:06:12 -0500

Hi All, In the file /etc/default/grub, I updated the timer value (5 seconds to 10) and created a new .cfg via grub2-mkconfig -o /boot/grub2/grub.cfg. After restarting, GRUB's timer reflects this change. However after selecting any of the Fedora entries, my system doesn't load (no blue progress bars - just dead screen). I had saved the .cfg before creating the new one so I was able to restore my system. Background: This is a new 19 install. However, I had to remove nouveau to support nvidia since my video was freezing. This process (as described in a link I'm not permitted to post, yet) worked perfectly. I've "yum update"d 19 so everything is current and I've had the system up/down many times. As of right now, grub is restored to its original values and the system is great. My question is, how did making this simple change corrupt the .cfg file? I did a diff between the old and new and notice there are more differences than just the timer setting. Specifically, nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off is missing as part of two kernel entries in the "new" .cfg file. I'm relatively new to LINUX so I did some snooping before attempting to change my .cfg. I didn't find any other procedure mentioned prior to running grub2-mkconfig. Any help would be welcomed. Thanks

Contents of grub:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXPAYLOAD_LINUX=text

Diff of .cfg files (old <> new):

13c13
<    set default="${saved_entry}"
---
>    set default="${next_entry}"
59c59
< set timeout=5
---
> set timeout=10
74c74
<       linux   /vmlinuz-3.11.6-201.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us  rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
---
>       linux   /vmlinuz-3.11.6-201.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us  rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet
88c88
<       linux   /vmlinuz-3.9.5-301.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us  rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
---
>       linux   /vmlinuz-3.9.5-301.fc19.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 vconsole.keymap=us  rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora/root rhgb quiet
102c102
<       linux   /vmlinuz-0-rescue-7725dfc225d14958a625ddaaaea5962b root=/dev/mapper/fedora-root ro rd ...
(more)
edit retag flag offensive close merge delete

Comments

Would you post above the contents of your /etc/default/grub?

rickhg12hs gravatar imagerickhg12hs ( 2013-11-08 22:23:23 -0500 )edit

BTW, until you pass the stupid karma minimum, post URLs by breaking them up a bit so the filter doesn't detect them. :)

rickhg12hs gravatar imagerickhg12hs ( 2013-11-08 22:25:40 -0500 )edit

Hi: could you fpaste a diff on the old and new cfg?

casep gravatar imagecasep ( 2013-11-09 07:38:24 -0500 )edit
1

One issue I see is that grub2-mkconfig wouldn't know about your problems with the nouveau driver by itself, you could try adding the missing kernel cmdline parameters to GRUB_CMDLINE_LINUX in /etc/default/grub before running grub2-mkconfig. Your screen staying black may as well be related to the nouveau KMS driver doing something stupid (and disabling it would work around that).

Nils Philippsen gravatar imageNils Philippsen ( 2013-11-09 10:17:57 -0500 )edit

Thanks to all for your comments. Here's URL to the nvidia update: if-not-true-then-false.com/2013/fedora-19-nvidia-guide/

bwolff gravatar imagebwolff ( 2013-11-09 15:17:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-09 17:05:04 -0500

bwolff gravatar image

updated 2013-11-09 17:06:22 -0500

Thank you, Nils Philippsen (how do I give you credit?) Per your suggestion, I grabbed the driver info that was resident in the working .cfg file

nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off

and I updated the /etc/defult/grub file by adding it to the end of the line ...

GRUB_CMDLINE_LINUX=

After running grub2-mkconfig and restarting, everything works great! Thanks again to all who responded.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-11-08 12:17:06 -0500

Seen: 2,981 times

Last updated: Nov 09 '13