Ask Your Question
0

Does Diablo 3 / Play on Linux work on 64 bit Fedora 19?

asked 2013-11-07 09:15:07 -0500

anffdraco gravatar image

updated 2014-04-11 16:01:42 -0500

remjg gravatar image

Noob warning (eager and able to learn)

My Distro:

Linux localhost.lan 3.11.6-201.fc19.x86_64 #1 SMP Sat Nov 2 14:09:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

fglrxinfo

display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: AMD Radeon HD 6700 Series OpenGL version string: 4.2.12422 Compatibility Profile Context 13.152

I'm a little confused as to the above fglxinfo return, as I installed the mesa libraries and the xorg drivers when I first installed / updated the kernel. I expected something more like the mesa version for open gl version and don't know if that means something isn't installed right.

In addition I've installed the 32 bit libraries after googling this problem and finding it's pretty common with 64 bit fedora 19 and amd cards. I have an amd / ati hd 6770 I watched a youtube video on fedora 17 64 bit playing d3 with it and figured his method would work, but his was identical to the ones for 19 I found and didn't produce results even with a fresh fedora install.

When I launch PlayonLinux (I'm trying to install / run diablo 3) it fails the 32 bit Open GL check BUT passes the 64 bit Check immediately after:

[main] Message: PlayOnLinux (4.2.1) is starting [clean_tmp] Message: Cleaning temp directory libGL error: open uki failed (Operation not permitted) libGL error: reverting to (slow) indirect rendering [Check_OpenGL] Warning: 32bits direct rendering is not enabled [Check_OpenGL] Message: 64bits direct rendering is enabled

I've tried to continue but Diablo 3 complains then I don't have a compatible video card and I can only assume it's related.

Anyone solved this problem yet able to give some help?

edit retag flag offensive close merge delete

Comments

I guess nobody solved this problem

anffdraco gravatar imageanffdraco ( 2013-11-10 19:36:14 -0500 )edit

so it looks like a possible workaround is to scrap fedora 64 for 32 bit or an alt 64 bit distro. ubuntu 64 is looking good. xbmcbuntu solves another problem ive been having with vlc on fedora and using hardware decoding... =D thanks for the info

anffdraco gravatar imageanffdraco ( 2013-11-11 18:20:17 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-01 03:00:42 -0500

For your video card, you need to install xorg-x11-drv-catalyst-libs.i686

sudo yum install xorg-x11-drv-catalyst-libs.i686

Got the answer from https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more
0

answered 2013-11-07 09:18:57 -0500

anffdraco gravatar image

reply test

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-11-07 09:15:07 -0500

Seen: 1,080 times

Last updated: Nov 07 '13